Blender baking all materials assigned to different images into one image

Hey everyone, I’ve been trying to fix this all day and I haven’t had any luck. Google can’t seem to help me either, I don’t know if I’m just searching for the wrong thing or what.

I did the usual workflow for assigning images to textures:

  1. Assign faces to material (I have to cut up things into multiple materials due to texture size limitations)

  2. Unwrap mesh per material

  3. Go through all materials, selecting only faces for material and create new image in UV/Image editor for each material

  4. Bake normals/textures/etc, all materials bake into one texture no matter what instead of the separate images I’ve assigned to each set of material faces.

I tried this in Blender 2.64.8 in Windows and a custom compiled Blender from SVN in Linux, and I always get the same result.

Is there some I’ve tried over and over and over again. I deleted all the images, tried adding new ones with new names, linking the object from a new blend, linking the mesh from a new blend (it just imports nothing), and all sorts of things, and no matter what it always bakes everything onto one image, and it looks like it’s the image I have selected in the UV/Image editor.

.blend file: cave 10.blend (813 KB)

Any help is appreciated. This isn’t the first time I’ve had this problem. I always just started a new file from scratch and moved on but I’m tired of wasting days of work and moving onto something else.

I am trying to bake normals from object for a low poly model for a game. I’ll bake the full render too eventually but I’m not there yet.

In the Object Data / UV Maps panel create a new UV Map.
Unwrap your whole mesh (Smart UV Unwrap for a quick example)
In the Object Data / UV Maps panel ensure this new UV Map is selected
Create a new texture in UV?Image Editor window
In the render / Bake settings select Textures or Full Render or whatever you want and press Bake
To rule out any lighting issues for textures you can set all the materials as Shadeless


cave 11.blend (912 KB)

I solved it by removing subdivision surface modifiers and replacing it with a multi-res modifier with a ton of subdivisions.

If this is a bug I will file a bug report. It seems like subdivision surface modifier ignores vertex to texture data and just does whatever it feels like.

Considering I have this in latest SVN and going back as far as 2.64.8 I think it is a bug. Would like some input if anyone else can confirm it.