Blender crash my Kubuntu Linux desktop

Hello! Apologies as I am new to this and if I might be posting things that is completely unrelated to you guys or if I am doing any of this wrong. Posted this on both Linux and AMD bug issue sites, and still awaiting for help on there but haven’t heard anything. I thought maybe you guys would be able to help me out. I’ve provided additional info of my system down below.
I am using Kubuntu 22.04 LTS with the latest 5.3 ROCM and HIP drivers from AMD to get Blender to pick up my GPU, which was successful and for awhile it ran flawlessly, but I’ve seen now that every once in awhile when I render a scene in Blender, it would freeze and crash the computer. Lately it seems like it crashes almost every time I try to render a file in Eevee.

There would be this graphical visual tearing happening on the screen as it turns back on and off consistently and never stops. You cannot do anything in this state at all and would require a reset of the computer.
I took a video of the incident that you can watch here of it happening after another render:
https://drive.google.com/file/d/11iaH1AkEOy8AE-8rCVF0LFIDnzC-YTAJ/view

After each crash, I would see this in the Compositor Settings of the system:
"OpenGL compositing (the default) has crashed KWin in the past.
This was most likely due to a driver bug.
If you think that you have meanwhile upgraded to a stable driver,
you can reset this protection but be aware that this might result in an immediate crash!"

Listening to the warning it was giving above, I tried to upgrade to the latest stable Mesa drivers.
So I upgraded from an older 20 version to 22.2.3.

Sadly it still crashed. Here is the info of my system:


I’ve tried multiple versions of Blender and no matter which one I use, this seems to happen consistently.
The versions I tried the most on were 3.5, 3.4 and 3.3s.

Is there any logs it generates somewhere for Blender or Kubuntu after each crash that you guys need? I’ll be more than happy to upload them here. Thank you so much in advance!

See BlenderDocu → Troubleshooting → Crashes and maybe also Advanced → Command Line → Command Line Arguments to get a precise log…
There may be a problem with X11 and OpenGL in general ??.. ( you may also consider to try Wayland)
And of course the posssibility of driver problems… for this card… (have to look into a kubuntu community…)

(using debian 9 with X11 myself)

Thank you for the reply @Okidoki ! I’ve tried changing to Wayland now and render the scenes again, but alas it still crashed unfortunately.
I am really dumb with this, can you tell me where I would click to find the “Troubleshooting > Crashes” and Command Line Arguments stuff? I couldn’t see that anywhere in my Blender menus or my Linux machine.

I should have probably done this from the start but I will report it as an actual official bug to the Blender team, but yeah I am pretty sure this is a Linux bug and not sure if they’d be able to help on this. I’ll try to do it regardless to see what they say in the mean time.

Well this time it was the first time i didn’t provided a link… and didn’t start with: Menu → Help → Manual : … which would open the blender docu webpage https://docs.blender.org/manual/

And this might be a special Kubuntu problem so you might have a look here: