Blender Crash on startup -- cannot read memory


(Lareon) #1

Blender (2.23 – is there a 2.25? I saw that posted somewhere but can’t seem to find it…) crashes for me whn I start it up saying that some command (a long hex number) was telling it to read memory address “0x000000” and that that block cannot be “read”, and then it quits.

Win2K, P3 650, Radeon 8500LE, latest DirectX, latest ATI drivers.

–Scott


(Jamesk) #2

Try to inactivate all DirectX-thingys. Run dxdiag.exe and switch off Direct Draw, Direct 3D acceleration and AGP-structure acceleration. Reboot and try to start Blender again. If it still doesn’t work, try to replace your graphics drivers with older ones (sic).

Hope this helps.


(Mutley) #3

Hi Jamesk!!
Blender uses OpenGL. Try cheking http://vrotvrot.com/support/index.php?key=OpenGL&show=both
and http://www.opengl.org/.
Check the OpenGL drivers that came with your video card.
Hope that helps.
Take care!
Mutley


(Dittohead) #4

Blender is OpenGL, no directx so i wouldn’t use ati stuff it sucks, no opengl support.

Get a GeForce card they FULLY supporrt OpenGL.


(Jamesk) #5

No shit?! On my machine Blender crashes if there are any DX-functions running. It apparently conflicts with the OGL-routines that Blender uses, so when I disable all DX-things, blender will run. I thought maybe the original poster had the same problem. This is why I used the word ‘inactivate’ - that is, switch off all DirectX-related functions, since you don’t need them for Blender anyway, and that they may, as is the case for me, even make it impossible to run Blender.


(Mutley) #6

Hi Jamesk!!!
Sorry about the goofing… Reply was intended for original poster, Lareon!!
But there’s one more thing. When I run a DirectX game, for example, and then run Blender I start getting problems in one or the other or both… Also the opposite, running Blender first than DirectX, also get problems…
If I start a session in Blender and stay away from DirectX I get a more stable environment.
Take care!!!
Mutley


(Jamesk) #7

Sorry too if I sounded a bit edgy… Haven’t had my usual 19 cups of coffee today, so I’m certainly a lose cannon… It’s odd however how DX and OGL seem to fail in their coexistance. It’s a windoze internal prob, of course… Where did Lareon go, btw? Did he get things running, or what?


(Mutley) #8

“Where did Lareon go, btw? Did he get things running, or what?”

Nice question…
I think he got Blender running and forgot everything else… :stuck_out_tongue:
Take care!!
Mutley