Blender crashes instantly when "click" on render image


I don’t know if I’m the only one with this problem, yesterday I was working on a scene in Blender and everything was fine, no problems at all.

Today I tried to carry on with it and render a preview when I got by surprise that it’s crashing all the time when pressing into “render image”. Not even a second, it crashes straight away.

I tried different projects and also a default one with just a plain cube and a sphere, (No textures or nothing). Continue crashing. Also, I download the latest version of Blender and it still.

I understand when some scene is too complex can happen but with nothing in it, is a bit weird.

Thank you.

Does it crash if you use supported rather than experimental? Does it crash if you render in eevee?

Hi Colkai, unfortunately, it still crashing even changing the render engine. I’ve tried all them but sti, :grimacing::grimacing:

It crash even rendering just an Override colour.

Hmm, if it’s doing it even with a basic cube scene, I’d suspect something to do with graphics drivers. Have you tried using CPU rather than GPU? Also, try downloading an older version, say 2.8 or even 2.79, from here, (assuming you don’t already have them):
See if they render ok, if say 2.83 renders, but 2.93 doesn’t, then for sure I’d suspect graphics drivers to be the likely culprit. Just see if it’s system wide or release specfic. :+1:

Hi Colkai,

I tried CPU, GPU… and still doing it. But I just download version 2.83 and seems working fine. I guess my computer is getting old and doesn’t support the latest version very well.

So I’ll stick to this one.

Thank you so much for your help.

No worries, my older laptop can only run 2.8 as well, and a friends ancient Pc struggles with 2.75! :crazy_face:
I updated my graphics card on this system for that reason, at present, whilst not blisteringly quick, a GTX1050ti allows me to run 2.93 & 3.0 With the prices of GPUs now though, upgrades can be stupidly expensive.