Blender Cycles AMD Opencl It's possible working now.

I read in another thread… in a post of storm_st i thought, that this method is not working with a 7850… so the only graphics reported to “work” are the 7900 series.

I didn’t have enough information to ensure the compatibility with other graphics in the near future cause amd is not giving any information.

Btw apple said that blender will work in the “NEW” macpro so it’s possible that amd only focus now it’s to fix this in their latest gpus so it could work with 7900 and newer graphics (7900 series are Tahiti while 7800 are Pitcairn).

Anyhow i’m only speculating cause like i said amd is not giving any information besides that they’re working on it (from years now).

@ @Andrew_Gacia: I tested OpenCL a few days ago (found the secret startup flag) and I think I saw those errors too. I also see you have an empty render result… exactly the same thing I got (nothing renders and Blender is stuck at the “loading render kernels” stage).

Btw apple said that blender will work in the “NEW” macpro so it’s possible that amd only focus now it’s to fix this in their latest gpus

Apple develops the graphics drivers on Mac OS, so whatever happens on there is not necessarily going to be relevant for other platforms.

please help me, what to do :frowning:
i love cycles

Sadly I’ve no idea either. I asked on IRC and was told it’s normal, since OpenCL for ATI is so basic it’s a miracle if it would have worked at all :frowning:

It’s suppose that apple is going to collaborate with amd to solve the problem so amd is going to have the opportunity to port the fix to the rest of platforms (i hope).

allright, im going to buy new NVIDIA Graphic Card :frowning:

I tried the OpenCL rendering engine.
It kind of worked, but I didn’t get the speed I was hoping for.
I specified “Tahiti” for the “Compute Device,”
and the OpenCL kernel compiled without any problems.
Then something strange happened.
I got a negative value for the Number of Samples,
and the rendering was very very slow.
It doesn’t make any sense at all…
Does anybody know how to fix this?

@Ketsuo, what ATI card model you have?

If it’s a tahiti model it must be a 79xx series, what tile size are you using? i recommend 512x512, btw it’s not as speed as it must be and it has glitches with reflections.

Thank you for reply.
The card is HD 7950.

I’ll wrote a spec.
HD 7950 | i7 3930k | 32GB RAM | win7Pro 64bit

Hi, I have used several settings default, 256x256, 512x512, progressive, same errors.
Maybe this helps you a clue.

And it seems to be Shader related issue

EDIT: in this case, the displacement, makes this OpenCL issue with the Headlight glass, and the tires (it is not well visible on the printscreen) … after disconnecting the displacement the shader works fine

YESSS!!! Finally guys!! Latest Catalyst 13.8 Beta 2 (released 19th August) is working fine with latest Cycles OpenCL Renderer (Blender 2.68a)! No artifacts, everything is working fine! Thank you Cycles Devs! Thank you AMD! It’s not fast, but it doesn’t matter first. OpenCL Support was halted due to compiler issues. Now, the compiler problem seems to be solved and the Cycle Devs can finally work on optimizations and more features :)! I’m so excited right now!

//Edit: Rendering MikePan’s BMW took 2:37mins (vs 2:57 of my CPU Intel Xeon E3-1245v2 (Quad-Core Ivy-Bridge with SMT enabled @3.4GHz / 3.8GHz Turbo)) after Kernel Compliation, about 7:30mins inlcuding Kernel Compilation (only on first render). It looks quite promising for the currently outdated / unmaintained OpenCL Cycles code. I’m sure, performance will greatly increase in the next weeks / months!

I noticed improvements with the Latest Catalyst 13.8 Beta 2 but still does not work 100% for me. If I set “PROCEDURAL_TEXTURES” compilation takes too long (think takes 1 hour). For me the biggest benefit would render with CPU OpenCL Intel + GPU OpenCL AMD, however this only works if both compile only Ambient Occlusion. =(

22 seconds holy crap
my fx 8350 does 6 seconds lol
did you mess with your cpu clock?

and my gtx 560 can do it in 1.4 seconds
gtx 460 in 1.73 seconds
gtx 560 + gtx 460 in .93 seconds :stuck_out_tongue:

well your one of very few to have success
i dont think thats enough for them to start working on opencl just yet :stuck_out_tongue:

Yeah for what i heard only the 7900 or newer cards are working :S but it’s nice to know that the artifacts are solved with beta 2.

that is awesome awesome awesome news.

Hey Guys,

I just installed AMD Drivers 13.8 beta 2 with Blender 2.68a and followed your tutorial and it it crashed whilst trying to render, but when i disabled everything except SVN and Emission in the kernal types.h file i was able to compile in 30 minutes and i can now render Cycles on my hd6950, it seems that the drivers fixes not only work with hd79xx series

Thanks for the guide much appreciated