Blender Demo.. see through prob I have a problem… when I fly up to high altitudes, my roads get grass lines through them… but there is one section of road that I joined, that doesn’t do this… can this be explained?

Tried to open your file in Blender Pub after downloading and got a ‘file not recognized’ msg from blender.
Since I can’t see the file I’ll take a wild guess that perhaps you have have your camera clip end set too short to show some areas and their therefore ‘invisible’. Just a guess.

I guess I can deal wif a see through chair :stuck_out_tongue: thanks for your help, I guess you can’t have clip sta too close or far away :stuck_out_tongue: dang

THanks for your help, that is exactly what I needed

You might be able to do an IPO that changes the camera clip end according to some game parameter. Not sure since I haven’t worked with games much, but it seems like it should be possible to do.

go to edit buttons on the camera selected and there youll find the clip settings.


it is due to zbuffer error

laymans terms:
your computer can’t tell if the road or grass is closer to the camera. On some places on the screen it thinks it is the road, and others it is the grass.

There are two solutions
adjust your clip settings dynamically so that they are closer together as you get further away from the ground. (difficult)

make it so your grass is not below your road: model so that the faces do not overlap, make them meet at an edge. (time consuming but worth it)

I have no idea what you mean by “dynamically” in blender :stuck_out_tongue: but that near function will do for me :stuck_out_tongue: ipo’s here I come… (if it does a clipsta ipo)

I’ve never tried or heard o using camera ipos, so good luck on that one and report back if it works or not. The techie term for this phenomenon is z-fighting. I have looked into a method to eliminate this problem, but you’re best bet is to space the polygons in question further apart. Sometimes just a few .001 units more than they are will do the trick.

well, :stuck_out_tongue: that .001 was actually . um… 5. :stuck_out_tongue: you get the picture, I used at least five spaces, and the z buffer still did not agree… but I’ll try that ipo method