Blender doesn't see NVIDIA GTX 980 Ti on Fedora 24, only offers Compute Device: CPU

I suppose the problem is similar to this here, except I’m running Fedora 24.

My NVIDIA drivers are installed but Blender only has one option for Compute Device in the preferences: CPU

Tried (just for testing purposes) to run Blender as root (via sudo blender) but it’s the same there - no GPU options available.

Any idea how to fix this?

Some (rather old) threads regarding Fedora:


Perhaps one of this helps?

I’ve seen those but they didn’t really help. Either I’m doing something wrong or they’re not the solution.

Did you install nvidia-driver, nvidia-cuda-toolkit & nvidia-modprobe?

Mine didn’t work until I did all three, it’a all in this thread post #4 I know mine is Ubuntu, but I believe it’s the same for Fedora…

Cheers, Clock.

I installed the drivers and CUDA toolkit, can’t find an extra modprobe installation for Fedora.

Are you using Blender installed from repositories or official Blender?

Are you able to open Nvidia Settings GUI to configure the nvidia driver?
What you get with this two command from the terminal?

lspci | grep -iE 'vga|3D'
cat /proc/driver/nvidia/version

I have it installed from the repositories but I also downloaded and extracted an official release build from blender.org and when I ran it, the problem was the same.

Ok, it seems that the nvidia driver is properly installed. It’s weird, because official Blender comes with precompiled CUDA kernels, so you do not need install CUDA Toolkit for developers. But you need install CUDA runtime library ‘libcuda’. So you should look about it:
https://ask.fedoraproject.org/en/question/76256/how-to-install-libcuda-on-fedora-22-so-that-blender-finds-the-cuda-device/

You always do the tests with official Blender.

I also recommend discuss this in a Fedora official forum, to see if they can make this easier for the user.

Edit:
Another thing, 370.28 driver is the latest driver (recently released), I have not tried it yet. So if you still can not make it work, just in case you should try with 367.44 driver (and checking that libcuda for that version of the driver has been installed)