Blender dont use my GPU like Cycles Engine Device (CUDA and OptiX)

Hey all! An error occurred this afternoon, after which I could no longer use the GTX 1650 as a Cycles Engine Device. I reinstalled everything, all drivers (for GPU and CUDA), but after I started checking which versions of Blender have the same error, I found that it is in each. I also deleted the old AMD drivers, but it’s useless, I’ll be very grateful if you help, I have a project soon, and there is no other card.

i’m using usually 3.0, but problem on all versions, here crashes from 3.0 and 3.2 (dont watch on errors of addons in 3.0 crash, its my broken some, need to delete them later):

google drive:

UPD: forgot to say, blender says about: require NVIDIA GPU with comparable capability 3.0, but GTX 1650 have more than 3.0, whats wrong here ;-; (added pic of problem in the same folder with crashes)

UPD 2: Reinstalling of OS is helped, no one solution dont worked, only this. Maybe something wrong happened in the system, so its better to just reinstall that.

Welcome :tada:,
sadly you already reinstalled everthing and can’t show nobody what might be the errror anymore. Additionally you deleted the old AMD drivers ?? So your system was already in a weird condition !?
So you registered here and want us to download you files from elsewhere… okay… it seems you are using the steam version and the 3.0_blender_debug_output.txt is telling a dozen times something like ModuleNotFoundError: No module named so it seems it’s not proper installed ?
And the 3.2_blender_debug_output.txt says
HIPEW initialization failed: Driver version too old, requires AMD Radeon Pro 21.Q4 driver or newer

So you may use an GTX and an AMD Radeon Pro but because you deleted the AMD drivers blender is complaining… so you may use a newer driver as blender is suggesting ??

I deleted all related to AMD drivers via DDU, so it can’t be possible.

About 3.0 crash, here so many plugins which broken and they just saying about their problems (i will delete them later), and bc of that I sent crash of 3.2 with default setting and the same error

Also I found one mistake in my GPU via Geeks3D: No CUDA support

If you driver info says no CUDA support (this is slightly different than simple graphic card drivers) … then (of course) blender can’t find it… So if you say:

then you used it before… so something changed your CUDA support… Only partly driver update ?

And according to:

I wouldn’t know of your Radeon if the logs didn’t tell me you graphics cards name…
Anyway: i’m not aware of that blender stores which device to use and persists on using it even if it is removed (?)… You may be successfull by removing your user settings and start blender clean? (After updating your Nvidia CUDA support.)

3.2 is fully clean and the same problem:

I’m still think problem with GPU, bc it says NO CUDA SUPPORT, mb I need to reinstall windows? I dont really know ;-;

Did you install new GPU drivers? Blender’s new versions want new drivers, and if you don’t install, GPU does not show on CUDA tab.

Second options:

  • Use this software and clean completely your drivers: DDU
  • Open Safe Mode your Windows.
  • Reinstall your Nvidia drivers.

Did it, nothing. Deleted all drivers for NVIDIA via DDU (in Safe Mode) and reinstalled all drivers for Nvidia GPU and CUDA, nothing, the same problem. Still No CUDA support.

Try install CUDA Toolkit.

Select only Custom > Driver components (if you want you can install everything) and restart your computer.

dont working, I did that all

I have GTX 1650 Super and I am using 497.29 driver. Try this, maybe will work.

i’ll try, will write when install that

Then try reinstall your OS. If still not work, try firmware update, but be careful.

1 Like

okay! Thanks for help, brb in 1-2 hours

1 Like

Okay, its helped, something happened with OS inside, but now it fixed by reinstall of OS, thanks for all help :heart:

1 Like