Blender Game Engine problem with Physics

Scenery with 3 objects

the cube does not touch the ground when the game engine starts
and tried with 2 different physics, Rigid Body and Dynamic
try to change the values ​​of the options in physics, but it does not work, it makes the problem worse

if I do it with Dinamico, the cube does touch the ground but when climbing the slope it does not rotate in proportion to the degrees of inclination of the climb that is climbing, if I change to Rigid Body, the cube does not make contact with the terrain and it seems that fleet, if I change some options of this physics the cube falls a bit and reaches the ground but begins to bounce uncontrollably and does not stop, when moving it in some parts it touches the road and it trembles like crazy and in other parts it seems that it’s floating

I already try the most common solutions to this but I do not know why they do not work

I use UPBGE 2.3.0, and I do not think it has to do with the version of blender that I use, I just need a little knowledge of this area, I will put some images and a video to show it

couldn’t watch your image, but most probably it’s a wrong object size or parameters.
Start with the standard scene and cube, make it “Rigid body”, “Box” Collision Bounds, give it some “Motion” Logic
ant it should go on slopes without problems, I hope?

1 Like

with Y rotation Blocked Axis

without Blocked Axis

Advice Provided by Nicholas_A (

select object
Press: CRTL + SHIT + C
select: select: Origin To Center Of Mass (Surface)

SOLVED with logic bricks