Blender Game Engine Runtime Black Screen

Hi again, forum.
I’m participating in a time sensitive Game Jam for fun, and have completed a rudimentary game. At the last step of the process, I’ve encountered a critical issue. Exporting the game as an independent runtime and running it is giving me a black screen. Sounds play in the menu, and I can click to start the game, but everything is black. I would really like to submit this game in time tomorrow, but if I can’t find a fix for this, I’m afraid the 48 hours will end. The game uses GLSL and I have packed all external data already. The game uses materials but no textures.

I’ve uploaded the files for anyone who wants to look. The game runs normally in blender but fails when the exported version is run.
Blend File
Exported and Zipped

I thank anyone in advance for your timely responses. This is an issue that plagued me in the past on a different computer and in a different version of blender, and it prevented me from completing that project as well. I’d like to put it to rest.

Edit: I’ve submitted the project anyway, now that I know others aren’t getting the issue. I don’t have time to troubleshoot it and I had to get it out the door. I’ll happily read any other suggestions. Thanks for the feedback.

The game is not black on my computer. It works fine.

I don’t know what to do with this information. That’s pretty unexpected.

What version of Blender are you using? Trying a newer/different version may solve the issue.

exe works here. starts in a window, not fullscreen.

Windows 7 64bit
Intel i7 4700mq
Geforce GT 755m
8 GB ram

after looking at the blend, you have some scenes in glsl, and some multi-texture. this could be reason for strangeness.

I’d suggest submitting it anyway if you run out of time and haven’t found the solution. Blender has always had a rough history with integrated Intel graphics; it’s probably just that. Particularly the HD 2000/3000 has lots of trouble.

I’ve also noticed AMD/ATI do interesting things when you don’t do things consistantly, like Daedalus_MDW mentioned. Mixing quads and triangles seems to upset them sometimes too.

Aha, it is a laptop, integrated parts and all. A low end one at that, with a RAM upgrade I installed a while ago. It was a struggle at times to complete certain operations. Other people with the same issue discuss graphics cards and drivers. That’s why i’m convinced my hardware was the problem. The standalone BGE has a rough history, period.

Hello everyone, I have a problem. which I cant find out what happened.
I made a little game about StarGate with DHD, when I hit the P key everything works fine, but when I try to make an EXE Runtime file and try to open it, it’s open but the screen is black and the cursor is not movable. Sounds works, so I tried to unpack and pack again all into Blend file. but still no luck.
Strange is: that another project I made also in UPGBE 3 based on Blender .2.92 works perfectly.
It looks like my player camera isnt as default camera , but it appears only in exe runtime file. not in the embedded player or standalone player. Please help. Thank you and If someone already try solved that, take my apology. Thank You