Blender internal takes forever with "blur 1...blur 2...blur 3.."

When I render my model, over half of the time is spent on some sequence of “blurs” that seem to do nothing. Each “blur” takes around 20 seconds, and have no visible effect on the renders. By the time blender finishes with its 8 or 9 “blurs”, it’s been about 5 1/2 minutes, very long for a 400x300 picture.

What are these “blurs” supposed to do? How can I get rid of them?

Somewhere along the way you switched the “MBLUR” option on. Switch it off.

It’s just to the right of the OSA button below Render in the Render Panel.

:smiley: Seems like that did the trick.