Blender is not recognizing my graphics card

Hello, everyone. I am running Blender 2.81a as of today, January 12, 2020, and it doesn’t seem to be using my graphics card to render in Cycles. My computer specs are: AMD Ryzen 2950 Threadripper cpu, 64Gbs RAM, ASRock X399 Phantom 6 motherboard, and an EVGA Nvidia Geforce RTS 2080 ti graphics card.

The operating system is Linux, Elementary OS (based on Ubuntu).

When I go to Blender’s preferences, in the Cycles Render Devices, under both the CUDA and the OptiX tabs it says ‘No compatible GPUs found for path tracing. Cycles will render on the CPU’

The drive I have from Nvidia is 440.44, as far as I can tell, the latest one. The results from my various searches on the internet show many people have this issue, but the posts are several years old.

Can anyone offer any suggestions?


What are your Nvidia driver files?
You need at least the G05 versions.

Hello, mahol. I am not sure what you mean by G05. The latest driver I have (I believe) is the Nvidia 440.44. Is the G05 something for openSUSE? The operating system I am using is built from Ubuntu.

Hello, indeed i use OpenSUSE. Recently I tested a RTX 2070. I had the same problem with the installed G04 versions of nvidia drivers. After changing to G05 all worked fine.

S  | Name                      | Type    | Version                             | Arch   | Repository             
i+ | nvidia-computeG05         | package | 440.31-lp150.20.1                   | x86_64 | nVidia Graphics Drivers
i+ | nvidia-gfxG05-kmp-default | package | 440.31_k4.12.14_lp150.11-lp150.20.1 | x86_64 | nVidia Graphics Drivers
i+ | nvidia-glG05              | package | 440.31-lp150.20.1                   | x86_64 | nVidia Graphics Drivers
i+ | x11-video-nvidiaG05       | package | 440.31-lp150.20.1                   | x86_64 | nVidia Graphics Drivers

Yeah, that G05 is only the package name under Suse. The interesting info is in the Version tab. As you can see @radius688 is ahead of you, so that’s not it.
I just tested with a fresh download as of now from
Here it works. Arch Linux current, package Nvidia 440.44-10 ( and after another update also with 440.44-11), 2x RTX 2070.
You can try to install Mesa, but that shouldn’t effect Cycles. TMK at least.

Thanks! The first thing I will do is to download the latest stable version of blender and then take it from there.

Currently running Blender 2.81a Nvidia RTX 2060 Super. Viewport is buggy. Sometimes showing life render sometimes not. Latest driver for the card 441.87. This is with Optix enabled in settings. I was wondering if 2.81a is still somewhat buggy or is it down to driver not being right ?

Wait, wait, wait, please. Before we get this topic mixed up.
I’m out of house right now and will comment on that driver thing later. For now, would you please state your OS?

I overlooked OP has Ubuntu so probably my reply is irrelevant here because I run Windows 10. Didn’t mean to mixed it up.

That’s what I thought based on the version number ;).
Anyways, maybe maybe hookup on a similar thread or if there is really nothing, then create a new one.

Good luck guys!