Blender is selecting vertices from behind WITHOUT XRAY

While doing retopology, I came across a super irritating problem of selecting vertices. Every time I use box, lasso, circle select, I find myself selecting not only the vertices from the front but also vertices from behind, which I cannot even see, (but they happen to align with the front ones) and don’t care to see, because I am not using x-ray for this exact purpose. This issue slows down the workflow by a lot . Tested on 2.8, 2.83, and different computers.

Please, which tickbox to click to solve this problem?

top right corner , turn off X-ray, this way background vertices disappear and can’t be selected.


But, i already have xray disabled.

hmm , its not supposed to happen, maybe i’m missing something else.

Can you try with other objects, etc. or give link to scene file ?

Welcome to the community, @Gorlomi! Have you tried turning on/off the OpenGL Depth Picking option in the Preferences:

Thank you!
Yes, i tried. No luck.

I was trying to reproduce with simple scene, and noticed something.
We all know that we can select vertices from behind. Well, i still can, even if there is another mesh inside, that is clearly blocking the view of vertices on the back.
I guess it is rather a feature, but i would like to disable it! :grinning:

So you’re saying you have an outer mesh and an inner mesh, and you are able to select through the inner mesh to select vertices on the back of the outer mesh?

Yes, exactly.

Are you using any addons or modifiers? A screenshot would be great - a shared .blend file would be great, too! You can use https://pasteall.org/pic/ to share images to link here and https://pasteall.org/blend/ to share .blends here.

No Modifiers, except subdivision, which I applied.
No Addons, except from those that have been added automatically by blender.

Here I proceed to select 3 vertices. And I end up with 14 selected, including vertices from the back.

Cant unfortunately add more than 1 pic at the moment.

It would be interesting if it can be reproduces by someone else, or i have 2 laptops cursed or something

I can reproduce, what you’re describing. It seems like meshes, that aren’t in Edit Mode as well, are not accounted for when occluding vertices from selection. I don’t know of a setting that would change this behaviour.

I’ve been recently learning about the differences in the selection tools, and I am curious:

Does this same behavior exists with the lasso and circle select tools?

Does this also happen for other selection modes (edge or face)?

Ok… this is normal.

Yes, it is also reproducible with lasso and circle selection tools.
As well as faces and edges.

But it is not what you would want. If i do not see a vertex, i dont want to select it, obviously

You should post this as a feature request on right-click select

1 Like

If you open an entry for the request, you share that image with the spheres and explanations you posted above and with a title similar to this: When selecting, respect occlusion by other objects in Edit mode

So, to make it a little less confusing than this thread.

1 Like

Okay, very weird question: Now that 2.8x allows multiple objects in Edit Mode, if you have both your inner and outer object in Edit Mode when you do your selection, does Blender respect occlusion?