Blender Layers & YafRay


my little Blender project, a little industrial robot animation, contains the robot, the lighting and the simple industrial (background) building in different layers.

When rendering with YafRay (0.0.9 & Blender 2.42a) sometimes Yafray renders a not selected layer ( the one with the robot) and I have not been able to determine what controls this behaviour.
Is there a difference between using the “Render” button and the “F12” function key ?

Also some of my area lights seem to vanish into nirwana.

The industrial building has clerestory (overhead) windows on it’s four sides, which I have covered with one area light on each side.
I have also added 25 planes with “emit” set to 1 to simulate artificial lighting in the building and have each plane/light covered with a little area light.

When I start the render (full GI) though I can see in the YafRay console window that only 25 lamps have been found. The 4 area lamps covering the overhead windows seem to have vanished.

I would appreciate some help.


Reference the area lamps: Yafray only supports “Square” area lamps. Make sure you haven’t set them to “Rect” in the lamp panel.

Ricky Dee


thanks for the reply. Before I had a chance to look at your reply I found that the only difference between the area lamps was that the lamps “internal” to my building were “square” and the ones covering the windows were square.

Somewhere I read that there is a difference between scaling area lamps with the s-key and setting the size in the lamp panel. That led me to the erroneous conclusion that this also applies to YafRay.

It is strange though that in all the tutorials and postings I have read I have not come across this issue.