Blender - need to activate?

Morning, today’s my first day with Blender and my first post here.

I have 2 problems in getting Blender working.

  1. I can’t select an object with right or left mouse-click… I’ve tried changing the settings in “user preferences” and it still doesn’t work. I’m using a Logitech Trackman Marble with Ubuntu 11.04 desktop if that helps any?

  2. I can’t import .py scripts so that Blender can see them. I’ve tried placing both the folders “addons-extern” and “addons-contrib” in blender2.64/2.64/scripts and then restarting Blender; and I’ve tried using the “user preferences>add ons>install add ons” method within Blender. Neither work.

Do I need to register or somehow activate Blender for it to work?

Many thanks for your patience

Rob

  1. I can’t import .py scripts so that Blender can see them. I’ve tried placing both the folders “addons-extern” and “addons-contrib” in blender2.64/2.64/scripts and then restarting Blender; and I’ve tried using the “user preferences>add ons>install add ons” method within Blender. Neither work.
    What scripts are you wanting to use. Do the scripts actually say they are compatible with the version of blender you are using. If not they they most likely won’t work. When you yay they don’t work, is that they don’t show up in the addons panel or don’t show up after you have enabled them.

Do I need to register or somehow activate Blender for it to work?
No

Hello, Richard.

The script I’d like to use is a toothed gear generator.
See here:
http://www.swineworld.org/blender/gears/#installation

My Blender doesn’t register it as being added.

Other problems are also developing.

Re the mouse problem - circle select was working an hour ago, but won’t work now. Select all/deselect all is the only selector working now.

I can’t get the “user preferences” window to close and now have 2 windows open in the workspace.

I went for the nuke it solution and tried a re-install - deleting the whole Blender folder and then re-unzipping the original tarball, but when I opened the “new” Blender, the same problems were there right from the program opening.

Next, I went a step further and deleted Blender again, emptied the recycle bin, re-booted my system, unzipped the tarball again and still had the same problems from the initial Blender window.

Does Blender store information on my system somewhere?
I’ve run a system search against ‘Blender’ but it didn’t pick anything up.

Frustrating, to say the least.

That script was written for a very old version of blender, the author will need to update it to work with a current.
Alternatively try the ‘Extra Objects’ addon that comes with blender. This includes a gears option.
If you need to reset blender you can use the File / Load Factory Settings menu option.

Attachments



You said that you’re using (old version of) Ubuntu. Don’t try to apply Windows troubleshooting techniques.

Does right clicking work in other programs? Could be a driver issue or might need additional configuration. Most straightforward way is to try with a normal mouse.

Latest versions of Blender might need some library that is too old in your system and won’t work because of that. If that happens, it won’t usually even start but might be a good idea to launch Blender form the command line to see the error output. Ctrl+alt+t to launch terminal and use cd command to change directory where you have it unpacked and launch Blender with ./blender command.

If you haven’t already, check if there are additional drivers available.
http://static.howtoforge.com/images/compiz_fusion_ubuntu_10.10_nvidia/big/1.jpg

Blender <2.64 saves the default scene and some other files in
~/.blender/version/
(~/ means the relative path to user home folder and . in front of file/folder name that it’s hidden. Ctrl+H to show/hide hidden folders in file browser)
Blender 2.64+ saves files in
~/.config/blender/version/

Thanks, gentlemen.

Richard, that sorts out the .py problem… the problem was me!
I’ll try your “Extra Objects” and factory reset options today.

JA12, the mouse issue still remains.
I uninstalled 2.64 and found version 2.49b in Ubuntu’s Software Center. After installing, I found that I had the same mouse problem with both versions of Blender. I can’t select an object.

It’s not that the rmb isn’t recognised… if I click and hold, a menu pops up; and if I switch selection buttons in User Preferences in 2.64, then the 3D cursor control will swap from lmb to rmb.

I’ve tried another mouse - a standard 2 button scroll mouse, and the same problem is there.
Both mice work perfectly in all other applications except the two Blender versions I’ve tried, and I’ve never had a problem like this before.

I’ve deleted both the ~/.blender folder and the ~/.config/blender folder, and will reinstall 2.64 today.

What do you think…

Could this be a Blender problem or is the problem in my system?

Is there anything I can change in any configuration files that might help?

Thanks again.

Rob

Everything is possible but I can’t see why the problem would be in Blender. It only needs to know when a button has been pressed and system provides that information.
There is one thing that might be the culprit and that is the desktop effects (Compiz). All Blender versions use OpenGL for the UI and so does Compiz, which even has separate mouse polling functionality. Could be some old bug in it that is causing this.

Try disabling desktop effects. Ubuntu has its own setting for desktop effects but if you need further control, install programs fusion-icon and ccsm. Fusion icon is a tray icon that allows you to change window manager, reload it if there’s a problem, and provides a quick access to ccsm (compiz config settings manager).
If disabling all effects resolves the problem, you could then try to disable individual effects from ccsm and see if it’s the mouse polling or some other that caused it.