Blender not rendering with GPU

Hello,

I have a GTX 1650 (4GB GDDR5). When, I try to render with my GPU after clicking on GPU Compute, Blender renders with my integrated graphics card (UHD 630), despite setting my Cycles render device to my Nvidia card. In Task Manager, the integrated graphics card only 1-5% of its power, whereas my dedicated graphics card uses 0% of its power.

How can I solve this?

Check your Preferences, under the “System” submenu, look at the section titled “Cycles Render Devices”. You should see a “CUDA” button, which should be blue/selected. If it’s not, click it to select it. Beneath that, you should see a list of your available graphics processors; in my case, I have a GTX 1070 and my integrated graphics processor. Make sure either just your GTX processor is selected, or both if you want both to be available. See the screenshot below for an example of what I’m talking about:

Hope that helps!

I’ve done that but Blender still doesn’t render on my GTX card. Even when I click on GPU Compute, Blender mostly renders on my CPU and both my integrated and dedicated GPUs rarely go above 5% of usage. Sometimes, my dedicated graphics card isn’t used at all.

I’m not sure what the problem is as I have already selected my GTX card in System Preferences.

Just a question, how long does it take for you to render the BMW scene on your GTX 1070.

How do you check if your dedicated GPU is used? Because the normal usage in the taskmanager isn’t the part of the GPU that is used by Blender. Blender only uses the CUDA cores as they are the things that make rendering fast.
You need some other hardware monitoring tool to see the correct GPU usage.

If you’re referring to one of the Cycles demo files from Blender.org (which I’m pretty sure you are), when I render that at the default scene settings it clocks in at 1 minute 53 seconds. If it’s been a while since you updated your video card drivers, I’d recommend doing that.

One question that just came to mind: other than the seemingly low percentage of usage for your dedicated GPU, what is giving you the impression it’s not being used? If that BMW scene is the only one you’ve tried to render, it’s only set to 35 samples for rendering, which is actually very low, so your computer may not actually use many resources to render the image. How long does it take you to render that scene?

It surprisingly took 17 minutes to render at 35 samples. I was very surprised about this as it should have ideally taken 3 minutes to render. I did the test again and realized my GPU and my iGPU were not being used at all. My CPU was also using just 40% of its power. Prior to that, I noticed that many of my renders take longer than they’re supposed to (considering my hardware). I am a little worried about this as my computer renders 5x slower than it should and my GPU isn’t used at all. It does have an HDD instead of an SSD but I don’t think that has much of an impact.

Edit: Did the test again with my laptop charging and it somehow took just 2 minutes and 52 seconds to render.