Blender Not Starting!


I am running a powerbook G4 with tiger installed, and whenever I start blender (powerpc version), it actually won’t start, but appear and then instantly disappear from the dock. Can anybody help me on this?



I tried changing the color setting in system preferences to thousands, but still no avail :mad:. I really need to use this computer for blender…

I also checked the amount of RAM, I have 512 mb left, I don’t think that is too little…

Thanks All!


I just checked on my G4 iMac running Tiger, and Blender 2.48a seems to work just fine. The only thing I can remember having had to do to get previous versions of Blender to work on that box was installing the newest version of Python. Mac OS X comes with Python installed, but the version included with 10.4 is bound to be out of date by now. Do a google search for mac python, and see if that doesn’t solve it.

My Original Post:
Whenever I have this problem, it’s because, for one reason or another, my hardware or OS version doesn’t support the current version of Blender.

Are you using the most recent version of Python? Last time I checked, it was relatively simple to find the most recent version of Python for Mac OS X. Google search.

If that’s not the problem, try this link for older versions of Blender. Maybe there’s a less recent version that works on your system – if you can find out the newest release that works, maybe someone might think of a reason why newer ones don’t.


I’ve actually gotten the application from another working G4 and transferred it over. If anybody has this problem and replies to this thread, I will make it available for download on my website.