Blender not switching to object mode when selecting null

Not sure if this is a bug or if I am missing something.
When you are in pose mode after working with some bones, when you select a null or object in the outliner it stays in pose mode. Seeing as empties and objects do not have a pose mode you would think that it would automatically go to object mode, esp for nulls which have no other modes.

Is this a bug or is there a setting you can change?
I would have thought that when selecting an object, armature, null etc it would go to the last mode that object was in, eg edit for an object. Or at least default to object mode esp for nulls.

Anyone have any ideas on this?

This is normal, pose mode is specific to the armature you are posing.

You can select other objects in the outliner while in pose mode but that does not make them the “active” object. You are still in pose mode so the active object is still the armature.

This is useful for example when you want to parent an object to a bone. From the armatures pose mode you can select an object in the outliner then the bone and “ctrl p” to parent the object to the bone.

Edit “No, it does not work like this and there is no setting for it.”
I was wrong on this, there is a setting (see Hadriscus 's solution)

Thanks for the explanation, I guess it comes down to personal preference as to which way it should be.

I see what you are saying about parenting to a bone and it makes sense. But in my case and I would assume this may be pretty common. I had to parent a few objects to bones in this project when I set everything up, and a few more times during the project. But I have had to switch between posing a character and selecting other objects hundreds of times.
To me I guess its something that could do with a setting :slight_smile:

I don’t know if your workflow is normal or not, but if you have to do something hundreds of times and there’s no apparent route to do so in the native workflow, it might be worth your $$$ to commission a bespoke addon to do your specific task.

Will “Outliner-parenting” not do the task?

All I am doing is going from working with a bone to selecting a null and back again.
Some context.

I am animating two hands installing a catheter down the throat of a infant. Hands are controlled by bones, catheter is deformed with a curve which have nulls controlling the points of the curve via hooks so I can animate it.

So I will be moving the hands and fingers into a certain position and then I have to animate the catheter via the nulls to match up as it goes into the mouth and through the trachea.

There is a master null for the catheter which is dynamically parented to a bone in the hand.

I have used a curve to deform the catheter as I also have to have fluid go down the catheter, so animating some fluid going along the curve works well (geo, not particles).

I shouldn’t have to pay for a addon to be created just to select things.

As a comparison, Softimage (What I used before blender) doesn’t have modes as such.
If you select an object then want to select a bone you just click on the bone, its as tho it just treats it as an object rather than a bone, If you want to pose the bone you move and keyframe it as you would a mesh, no need to change modes, if you want to edit it, you just use the same tools as you would in a mesh. Much smoother workflow in my opinion.

But again its a preference thing, and just something I have to get used to, no software is perfect.

Unchecking “lock object modes” in the edit menu might help


Hadriscus, next time you are in Sydney I will buy you a beer. Simple tick box and all is sorted, ignore my previous ranting.

Thank you.

1 Like

Haha, will accept with pleasure if I’m ever in the vicinity

I was not aware of that option!

1 Like

IMO, it’s not so simple, it’s OBSCURE. So, please, RANT, it’s the only way the devs will get a clue that maybe that’s not as obvious as it could be.

The question is: where’s the best forum on which to rant?

BTW, here’s an excellent video clearly explaining the issue. IIRC, several YouTubers have wondered why the default on this is what it is:

As far as I know, this is so you don’t accidentally jump out of a mode by selecting another object, specifically while animating (pose mode)