Blender not working correctly on Linux?

This is how it looks when I select one verticie. There are no doubles, and I haven’t changed any settings. I use the Linux Mint 17 Quiana. I downloaded the official blender version for linux, so I don’t know what is going on.

Upload a example .blend file of the problem.

Hi, just a guess, this happens sometimes if antialiasing is enabled in your video driver setup.
Show us .blend is always the best.

Cheers, mib