Blender not working correctly with display tablet

I have recently got a display tablet (The ParbloCoast 10’) And I started using it in programs like krita and sculptris where it works absolutely fine, but when I attempt to use blender on the display tablet it slows to a crawl. I can use it fine on my main display, just not the tablet. Is there any reason this would be happening? It’s not because of my rig, I’ve got an i-5 quad core 3.2ghz, with a 750ti, 8 gigs ram and it runs just fine with sculptris. Meanwhile in Blender I can’t seem to even move the camera in the basic start up cube scene. Any help would be appreciated.

to verify - you are taking about a graphic tablet with a build in display like a wacom attached to your PC and you have a slow performance on the tablet when putting Blender on it?

Is it connected via DVI or display port?

Hi. Sorry to hijack, I am experiencing the same thing. All other applications work with viewport pan, zoom, move except blender. I have an Ugee display tablet connected through DVI.

My suspicion is drivers and windows10.

Or blender itself

I know blender on macOS has better UI roux and Trackpads Support than windows

It MIGHT be windows ink
Here is a solution for blender (if you can’t disable windows ink per program do it globally but it might how upsides and downsides)
Fist disable windows ink (for xp pen it’s GLOBAL disable for wacom you can do it per program)

then go to blender preferences and set it up to anything but windows ink (automatic is fine but try wintab first)

Let me know your results.