blender player letterbox issue

I have a a project that I am trying to maintain the rights on, so I am setting up a runtime that loads my blend file in fullscreen on startup. The issue I am having is that when it runs it has letterbox bars at the top and bottom of the screen, cutting off some of the visuals in my scene. When I build the main project file as it’s own runtime I don’t have this issue. I have set both the project file, and runtime starter file resolutions correctly on both the blender game and blender render modes, and set both to run fullscreen with the extend setting in the blender game options. What’s interesting is that when I first run the starter runtime it goes fullscreen with a soild grey image, WITHOUT the letterbox bars, but when it finally loads the blend file it starts rendering the bars. I’m at a loss.

what version of blender are you using?

2.57, i still haven’t updated, should i?

There was a bug regarding the Blender Player having different issues with aspect ratio before - it might have been addressed by 2.58a. Check it out to see if it’s alright.