Blender Raytracer Baker


(Arnie) #1

Can’t seem to get macouno’s Baker script to work.

In this test scene I have the default cube shaped slightly and a couple of lights setup.

The script runs and the faces are all rendered. But when in potato mode only a couple of faces are shown:

http://x10.putfile.com/10/29412462311.jpg

Can anyone give me a clue where I’m going wrong?

Thanks.


(Ben) #2

-The script has nothing to do with your problem.
Point the normals outside(Ctrl+N) for that faces…

Ben


(Arnie) #3

Normals are all pointing out. Sorry I should of made that more obvious in my 1st post.

When I go into face select mode the missing faces are not even selectable:

http://x10.putfile.com/10/29510575684.jpg


(Fligh) #4

Because their normals are facing away from the camera (and the raytrace algo’s vector). In F9, in edit mode, in MeshTools1 tab, turn on “Draw Normals” and turn up their N-size to see them.

%<


(youngbatcat) #5

nuh uh, It happens to me as well, I made a pretty flower and come back to it 40 minutes later to see the mesh wacked by the script. And I made sure all normals were faceing out, two sided faces were on and show both sides were also on. zich

Oh well have to wait for updates guesses


(Arnie) #6

Yeah it’s nothing to do with the normals. If you select Draw Hidden Edges (in the edit buttons under UV Calculation tab) you can see the rest of the mesh, but not the missing faces…

It seems you have to unwrap the mesh 1st before running the script to get a result.


(Fligh) #7

OK, I stand corrected. But then post this in macouno’s the original thread:

http://www.elysiun.com/forum/viewtopic.php?t=44144

Most busy people set a flag on their threads and are unaware that you have problems if you post elsewhere.

%<