Blender reboots my computer

For the last two weeks I have been having a real problem. I will open a file, (It doesn’t seem to matter which one.) start working with it and usually withing ten minutes, sometimes longer, the screen will go black without warning and the computer reboots.

I am not rendering, I am just editing mesh or working with the shader. I have been working with Blender for about a year and this is a new wrinkle.

What I know:
This phenomena occurs with Blender 2.83 and all later versions.
All drivers, including the BIOS, are up to date.
I took the computer to be serviced and they could not find a hardware issue, nor could they replicate the crash. However, the tech admitted he didn’t know much about Blender and didn’t really mess around with it. It tends not to crash if the app is open but not being used.
After considerable investigating I don’t believe it to be a temperature or power issue.
I have not had a problem with any of my other apps.
Crash logs do not seem to be generated. Event ID 41 & 161 occur each time.

My System:
Dell XPS-8700 with Windows 10
CPU: Intel i7-4790
GPU: Nvidia GTX 1660 Super
RAM: 12 GB Dual DDR3
HD: 1 TB SATA 7200 rpm
PSU: 460W

At this point, Blender is unusable. Which really sucks since I invested so much time in learning how to use it. I am considering getting a new computer that is much more beefier but if this problem is going to continue on a new computer, then why bother?

Any help would be greatly appreciated.

I’d say that you have an unrelated, and potentially serious, hardware problem. I’d suggest that you look carefully at your system’s “Event Viewer” (every operating-system has one somewhere …) to see if it is logging-out any sort of hardware problem, such as a disk-drive problem or a memory-parity fault. Application programs will never cause the entire system to reboot, but hardware issues definitely will. (e.g. “Heat? Are you running Cycles?”)

I would definitely either take this machine to a repair-shop or buy a new one … probably the former, at least at first, because these specs are pretty decent although you need more memory. Competent diagnosticians ought to be able to get to the bottom of this sort of thing very quickly – and the computer really won’t be good for much of anything until somebody figures out what’s really wrong with it.

1 Like

Hi @tenae,

Have you tried testing your memory? Here’s a good list of software options.

For hardware monitoring you can’t beat HWiNFO. I’d suggest using this to keep on eye on things. It can even create a log which might help you find the issue.

For drivers I use Driver Booster which can help suss-out driver issues. It did help me so I ended up going the Pro route.

Good luck!

Thank you for the quick responses.
I believe Blender was set to cycles, though I wasn’t working in rendered view.
I have been monitoring the heat and doesn’t seem to be an issue. It never gets that hot.
I did run memtest86. It didn’t find any errors but it twice informed me, “RAM may be vulnerable to high frequency row hammer bit flips.”
I have no idea what that means.
I’ve been pulling my hair out for while with this, but since it runs fine otherwise (That is, not Blender) I may as well use this as an excuse to get a better machine.

I just looked into what it means (“RAM may be vulnerable to high frequency row hammer bit flips”).

According to the MemTest86 site this indicates that the first of the memory tests did detect errors, but subsequent tests didn’t. It explains that this can mean that there are memory bits which are unexpectedly flipped during the test - and this normally happens due to voltage leaking across the bits in the memory modules. Memory in most laptops is just standard non-ECC memory but some higher end machines have memory with automatic error correcting (ECC) to detect and correct such problems. The XPS-8700 uses standard non-ECC memory.

It’s more likely to occur when the laptop/PC is under stress when doing a lot of work. So normal use of the laptop is fine but memory issues can occur when stressing the machine more. Such memory bit flips could cause small errors in rendering. But in theory they could also cause the reboots if it’s serious enough to cause the laptop to crash. But that’s not to say that it’s definitely causing the crashes. It might be or it might not be. If the laptop has memory modules that can be swapped by the user (rather than soldered) then it might be worth trying new modules. I think they are swappable on the XPS-8700? Or if there are options in the BIOS to slow the memory down slightly then it would be worth trying that to see if the problem goes away.

If it were me then I would also try reinstalling Windows and Blender, getting a newer GPU driver, etc, in case it’s something simple like a corrupted library on the machine.

Something else to consider is whether the machine could be overheating. So clear out any vents of fluff etc.

Thank you for the response. I updated Windows 10 to version 20H2 and did a clean install of Blender 2.91.2. I was then able to work with Blender for several hours without any problems. Then, alas, it spontaneously rebooted. I think it’s time to take it into the shop.

nah… forget about updates of system and apps. this is simple shit for common people.

As was previously said i believe you got a serious hardware problem.
This can come from many things…

  • disk
  • memory
  • mother board
  • any or all of your connectors

computers ONLY get old from 2 things

  • programs calculation power greed
  • false contacts du to oxyde

The 1st reason you see it coming slowly…
The 2nd comes from day to day and believe me it happens very often :confused:

from my ( long ) experience i’d say you can grab 6 month to 2 years of life by taking care of your memory boards.
They are the most stressed ( in frequency and speed ) bus. Oxyde is the main enemy ( lowering contacts quality leading to too big response delays ).
So 1st thing, put out your mem sticks and very carefully restore the golden contacts with a paper eraser. Take your time as you might have to spend 5 minutes rubbing the contacts.
On heavily oxyded golden pads you might want to use an matchbox scratchband ( it’s and extremely soft scratch paper that will restore the gold film without damaging it )

when those golden pads are visually sexy ( we all love gold and you’ll understand what means ‘sexy’ :stuck_out_tongue: ) plug back your mems, restart your comp and run mem stress test all night long.
If you wake up with no errors your mem is ok.

You might have to do the same with your PCI-e port…

If errors come from your disk… ( you can notice it from disks stress tests ) save ALL and replace it.
Buy 2 identical disks and make a raid1 cluster.

Be sure that your problem do not come from blender. Try to use another mem-greedy program and you’ll get the same crashes/blue-screens…

Hope this helps !


Happy blending :stuck_out_tongue:

I know this is late but I am only seeing this now. I had the same problem when I started using Blender for the first time a couple of weeks ago. This is how I fixed it.
Click on Render Properties then Performance then Threads. Click on Threads Mode and select Fixed. You should then be able to set the Threads to a lower level. I went from 8 all the way down to 2. It slows Cycles down alot but my computer doesn’t reboot any more. There is a long article by Blender Guru on how to speed up Cycles on YouTube but there is lots of web advice about how to speed up Cycles. Just Google it.