Blender render: New/Open image option disappears.

Excuse my ignorance. This is surely something well known, but I’m more used to Cycles, and I am getting lost when trying to follow an specific Blender Render tutorial.

I need to open a new image texture in the scene I’m working on, and to do that, I go to the texture tab, hit new, then on the class type, I select image or movie, and then It is supposed to appear a new option that asks me to either create or open a new image. For any reason, that option doesn’t appear.

Curiosly, If I begin a completly new scene, and I press the texture tab, new, class type image or texture, the options appears ok.

This is from a new scene:

And this is from my scene:

Someone could tell me why those options can dissapear, or what I’m doing bad?
I have tried to search for the solution, but when you enter the terms of this specific problems, millions of non related threads appear.

Solved. For any reason, options were unsorted. Options were up, instead down… Blender will knwow why.