blender runs too slow on my macbook

hi, i have the newest model of macbook and it runs blender too slow

i downloaded 2.46 and it runs slow as crap compared to my xp machine i used to use before

can people with MACBOOK not MACBOOK PRO tell me what version of blender to download

by the way the graphics chipset or whatever it has is this: Intel GMA X3100:

This problem has been mentioned a few times in these forums, for more detailed info you can probably google your problem and find the relevant threads that way. Currently, I believe, the main solution to this can be found here:

Hope that’s of some help :smiley:

i have followed that tutorial, all it does is run blender in full screen and then crash it

Wonder if Maya or C4D “runs normaly” on a MacBook or any non-professional typed laptop…

bump on this thread… please has anyone found a solution?

The easiest and most efficient solution, but not the cheapest, is to run Windows via Fusion, Parallels Desktop or Bootcamp and install the Windows version of Blender. Failing that, there is a thread called “Mac OSX Leopard : Will it work?” which discusses the problems with MacBooks. Other than that, from a fellow MacBook user, keep your version of OSX Leopard up to date (latest is 10.5.4) and test Blender after every update. I find that occasionally blender runs at acceptable speeds but never for extended periods of time.

As Nitronic755 mentioned. I have it running fast on a windowsXP bootcamp installation. There was another problem with the interface. You could not see anything typed in fields like Save as. For this I had to copy a .dll into blenders installation folder. Now it works stable and fast. Rendering times are great thanks to dualcore. I also use the Mac-Installation for Rendering, cause it works much better with “big scenes” that use a lot of memory.

i have followed that tutorial, all it does is run blender in full screen and then crash it

You may need to buy some extra RAM. How much do you use?

Hi.Can you tell me which .dll that was?I have that problem too. :slight_smile:

Upgrading your RAM increases the efficiency of the custom builds? I downloaded it ages ago but it wasn’t as fast as it as on Windows so I got rid of it, but since then I’ve quadrupled the RAM on my MacBook from 1GB to 4GB… I should download it and try it again.

Meh, wait till 2.5 is released, then wait till someone makes a Custom Build for MacBooks for that version. Much better idea.

I tried the OpenGL Profiler edit and Blender still crashes on me. I don’t know what else to do. I originally thought it was a RAM issue b/c I only had 1 GB. But I upgraded to 4 GB, which did pretty much nothing…what should I do?

you could try this build here:
it seams that this problem is fixed in 2.48, cause at least here on my MBP everything is fine, but of course that doesn’t have be be true for macbooks…

The problem isn’t present on MacBook Pros I don’t think, it’s an issue thats come forth due to the lack of a proper Graphics Card on Macbooks and Mac Mini’s, combined with some changes made between Tiger and Leopard.

It is because it is a MacBook and not a MacBookPro. Whatever you run is going to be slow.

Macbooks are perfectly capable of running most applications, especially after you upgrade the RAM… I run Leopard and Vista (without Aero) at the same time without any problems through Fusion, and as Blender refuses to work properly on Leopard I run it at full speed on Vista instead. I’m not sure what the problem is, but it’s something to do with Leopard because there were no problems when people were running Tiger and it still works on Windows.

I also have an Intel chipset w/ OpenGL support and the same issue. The interface works quickly and properly when I disable Direct Draws’ accelerator so that’s what I do. I only have to do it when running blender, but at least I’ve got my Blender. It can be done in DXDiag or by downloading and installing DX Controll Panel( Third party but usefull).I hope this helps.