Blender saves alpha channel as either fully opaque or transparent, nothing in between

See the following, here is the rendered image inside of blender… note that the glare of objects (through post processing) goes out beyond the edges of these graphics:

Now have a look at the output when this render is saved:

It is not saving the glare outside of the solid objects. How to make it save this like it’s rendered?

The output file save settings are PNG, RGBA with 16 bits depth.

You don’t have it set up so your post-processing is actually being rendered- it’s not about the alpha channel, it’s just that the “glow” effect isn’t in your final render. Check out this thread Saving image file AFTER render and compositing