Blender startup blank screen

Sometimes when I open blender it shows blank screen like this:
enter image description here

and if I open it from the terminal:
enter image description here

and refuses to close even if I kill the process from the system monitor
enter image description here

Can someone please urgently help? A lot of my work is pending because of this

My specs are:

AMD® Ryzen 7 4800h

GeForce GTX 1660 Ti Mobile

Ubuntu 20.04.4 LTS

Welcome :tada:.

Worked before? Since what update (driver/kernel…)?
Maybe with some other --log-level (1 standard. -1 all)… (+1 for )

the second image doesn’t really show much and

is sufficient to describe the problem.

Tried --factory-startup ?

1 Like

Worked before? Since what update (driver/kernel…)?

It’s been like this since I downloaded blender, sometimes It opens quickly, sometimes it shows the mentioned error

Tried --factory-startup ?

I did but it’s giving the same problem

other --log-level (1 standard. -1 all)… (+1 for )

I’m having trouble understanding how exactly to run this command, I thought if I entered blender --log-level -1 it should print out onto the console the startup processes that it was going through to debug

& Actually a new development, in frustration I left it in the hung state and after 5-10 mins it started