Blender took 180 GB in cache and I had no way of knowing it

Had to go show hidden files in win 10 and go to C:\Users*user*\AppData\Roaming\Blender Foundation\Blender\2.7

and delete it.

My 250GB SDD drive ran out of space several times.

Why is that cache folder hidden?

Probably because you never changed it.

I usually have mine set to c: emp, But I was just checking to see where the factory defaults are.

I guess I’m the only weirdo who constantly clears my %temp% folder

is there a way to auto empty that folder?

I almost forgot about it
and I had like 500 MB of files !

happy bl

This a short tutorial how you can auto clean it in Windows.

So if you don’t want to clean them by hand like me do this:

  • Setup a blender temp directory that is unique i.e. c:\blend_temp

  • Create a folder to store the quit.blend (I really don’t understand this file so better keep there) I have C:\codes

  • Set blender to save it’s autosave files there.

  • Create a batch file to delete the files. open notepad and type in the command


 copy C:\blend_temp\quit.blend C:\codes
del c:\blend_temp\*.* /q
copy C:\codes\quit.blend C:\blend_temp
del C:\codes\*.* /q 

Save the file somewhere you will know how to find it. like c:\del-blend-temp.cmd

Run it when you want to clean your tmp folder.

I recommend You guys sometimes use programs like WinDirStat:
Sometimes crappy programs (and even windows itself) left garbage.

1 Like

This issue has annoyed me for quite awhile. I’m on Linux and Blender kept dumping 400+ gigabytes of cache in ~/.config/Blender until the OS gave me “disk space low” warnings…

Serves me right for not knowing about that hidden folder or that Blender dumps cache there and never deletes it by default?

@SterlingRoth Close, but wrong - this is about the place where Cycles stores files when “Cache BVH” is on. If you’ve used that option at any point in time, i suggest checking your C:\Users*user*\AppData\Roaming\Blender Foundation\Blender</b> folder for garbage files. You’d think it would be set with the “Render Cache” path but no, it doesn’t work, just checked. So there is no way to control it other than to delete the files manually or just not use “Cache BVH” like i did.

Oh, I never use cache bvh. (is it still an option? I thought they removed that recently, but it might have been after the freeze for 2.76) When I tried the Cached bvh, it took more time to load the cached version than it took to build it in most scenes.

I’ll change it but it’s not really user friendly.

I did run the windows cleaner and it did not find that folder.

First, don’t use “Cache BVH” unless you know it gives a speedup (e.g. when animating a complex but static scene), because it can also give a slowdown.

Secondly, “…/AppData/Roaming” is not a folder to store temporary files in, it’s where programs store all their settings. It may be a hidden folder in Windows, but users should still be aware of it. It’s not generally safe to delete anything there, so no sane “cleaning” application will mess around in there. Putting the cached BVHs in there and never deleting them is a pretty bad design decision, if you ask me.

For all I can tell, it’s also not the case that this can be configured, because (as Pesho points out) the BVH caches are not stored in the “Temp” folder specified in settings. The default for that is “…/AppData/Local/Temp”, which is a system folder meant for temporary files, and it is cleaned by Windows Disk Cleanup.

Here is a report on the issue.

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”