Blender & V-ray test

Installed Blender with V-ray exporter (thanks to Sebastion’s free tutorial on cmiVFX and Andrey Izrantsev’s exporter coding). Blender w/V-ray from
Testing HDR angular maps and reflections.
I don’t know what setting to make it less grainy, but this is just after 7 minutes.
Can’t wait till Sebastian get’s his full tutorial up on cmiVFX.

Looks good, nice test.
I think the setting is time itself. Just let it continue to render.

So does v-Ray offer a free single core license or is that 3Dlight?

Actually when it’s done, it’s done. Not like LuxRender where you can let it run forever.
I’m thinking the number of samples somewhere is what tells it how long to run.
I’m using the demo version which is free.
See cmiVFX for the free tutorial on how to install it.
The single license is $490 and needs a dongle for $35.
If you bought the Maya version, it would run you $1300, but with the Blender exporter code you only need the Standalone version.

@Atom: Vray offers a free trial version where you can render up to 640x480 or thereabouts with a watermark.

On the noise front, try turning up “min samples” in the DMC sampler settings, also the number of subdivisions on any lamps/environment lighting in the scene.

I’d rather leave min samples where they are. use the adaptive DMC image sampler and set max subdivs to something higher, try 8 or 12. lower the dmc sampler threshold to 0.005. leave light subdivs etc at the default.
might be a good start to get rid of the noise.

@ben, actually it is 600x450 :slight_smile: - what sebastian uses… with his full version lol :smiley: (no watermark)
I wonder why this odd resolution - maybe to query faster for renders with their demo version in google :smiley:

I have no noise problems, my problem is, that I can´t get a “worldtexture” to work. Is there a magic button somewhere to activate it? I guess I just turned optionblind today, by now I am sitting… hmm. almost 16h in front of blender lol… might be bedtime soon.

So yes, lowering the threshold did get rid of a lot of the grain.
Then I got rid of the angular hdr map and just dealt with a sun, and it was almost no grain.
Then I started to get some sparkles and figured the file got corrupted, so started over.
Now, even with the sun I have grain again. So I’m beginning to agree with your tweet Sebastion, that Vray is pretty complex.
Here’s a few renders lately.

The first is starting over with a new file, sun, but weird render.
The second is the corrupted file or something.
The third is lowering the threshold to .001


Added sky textures, and the sparkles came back.


what samples do you have in your lamps? try using 16 or 24 not more than 32

I don’t see a ‘sample’ setting in lamps. (see pic)

As for the sparkles, checking ‘Invisible’ in the lamp section got rid of those.


subdivs = samples in max. set it to 24 for less noise

Looks nice, I don’t really know enough about Vray to give you advice so that’s all I can say for now :[

Anyway could you please post a link to that free tutorial you were talking about? I’ve searched all over cmiVFX and I couldn’t find it.

@StieMO Mine is set to 8 then. I’m thinking the Angular Map is what is causing the noise as it doesn’t show up with the lamps. I’ll try other Maps later to see if they result in the same noise.

@ NinthJake I think you have to register. (actually I’m pretty sure). I don’t see it until I log in, then it’s under the ‘Blender’ section.

Seems like it’s grainy when using HDR environment maps. This is a higher quality, but still there is grain. Not sure if that is the map doing that or if there is a setting that would improve that.

could u post a blend file, i want to try it my self

I haven´t tried it in vray, but that is why environmental maps usually are available in a high resulution and a low one.
You use the low one for IBL, because high resolution images for lighting cause those lighting artifacts, while you use the high resolution ones as world texture. I am not sure though if you can seperate those in vray but I am almost certain.

Right now these are applied to the world texture, so initially I’m thinking the Irradiance Map settings are going to be what control the GI from the texture.

Here’s the .blend:
The HDR map comes from

here are a view pics and the blendfile i changed.

Look at the material subdivs. And the fresnel effect mirrored your reflection (like glass do). Use a chrome mat for tests like this.

if u have questions about some settings. i will make u screens, later

My first question is how do you get your renders saved? My VFB acts like it will save, but then there is no file.
If I return file to blender, it is lighter.
If I check ‘output’ it exports the file without the world texture.
I’ve been doing a screen grab.
And the other one I have is what setting makes the plane ‘shadows only’?


settings for only shadow:

i saved as jpg, because it has no Alpha. Backplate is set as wold texture and wold = alpha 0: