Blender viewport lag

I’m not sure if it’s even related, but in the top right corner of the viewport, you can see it shows 5FPS.

I just downloaded Blender today and been trying to fix this problem for hours. My Blender is lagging, everything is unresponsive and the viewport is 4-10FPS at all times. I’m running out of ideas what to do. I posted this to other forums and searched the internet to try any solutions provided, but no success. I ran Blender on an older computer and everything was smooth and responsive.

I found out one thing - if I make the viewport smaller, then it doesn’t lag anymore (top-left corner shows FPS if that is of any help).

And if the window size is still maximum, but I make the viewport small, then nothing lags as well. But why should even lag when it’s bigger if nothing is taking CPU/RAM? This is how everything is when Chrome and Blender are running (CPUID HWMonitor):

More (probably not important) from HWMonitor:

What I tried to do so far:

  • NVIDIA Control Panel, disabling FXAA
  • Couldn’t find a setting for integrated graphics, nor could enable it
  • Disable Shadowplay and restart PC
  • Update NVIDIA drivers and downgrade to an older version
  • Re-installing Blender (twice)
  • Changing Blender settings like filtering and window draw methods

GPU: NVIDIA GeForce GTX 1060 6GB (no OC)

CPU: Intel i5 4460 (no OC)

Motherboard: MSI B85-G41 (MS-7850)


OS: 64-bit Windows 7

I really want to use Blender but sadly it’s unusable right now. If there is anyone that has any ideas on what I could try to fix it, please tell me. I’m willing to donate my soul for a fix.