Blender won't select an edge loop unless you use the default navigation scheme??

Hi everyone, i downloaded and began learning Blender a week ago and have been enthralled with it to such a degree that i’m actually laying Harmony down for a while until i can learn it - so i can eventually use the two together. Because i already own Harmony and am fairly well versed in 3D, i’m picking up Blender rather quickly.

I’ll get to my question in a moment, but since i’m new here i just wanted everyone who either uses Blender, is a programmer, or helps in it’s development, that you can definitely count me in to help in any way i can, here on the forums, as well as in supporting it via purchasing add-ons and donations. That’s how excited i am about this app. I mean, i’ve always known about Blender, but i just didn’t pay that much attention, it being 3D, yet free; so in my mind it couldn’t be that great since 3D, in and of itself, is pretty complicated to say the least. And you only pay big money for programs of that nature (as i did with Harmony, which is in the same $$ ballpark as Maya).

Anyway, as i was enjoying the benefits of using Harmony, i decided to give 3D a try; possibly using them together to one day create some really cutting edge movies. I just didn’t know how deep, workable, user-friendly, and stable Blender was. It’s FREE and i’m more excited with it than i am with Harmony. I’m hooked.

My question is: Is there a script anyone is using (or could be written) whereby i could keep the left mouse button functionality of holding down the Alt button so to orbit the scene, without having to sacrifice the selecting of an edge loop. When i enable left mouse button functionality in Preferences, it gives me orbiting control, but it disables edge loop selection. If i enable right button functionality in Preferences, it disables orbiting control, but it enables edge loop selection. Haven’t you guys come up against this situation? I’ve searched the forums and net for this btw and haven’t found a specific and real solution. Can’t i have my cake and eat it too? :slight_smile:

Much thanks for any help you can offer and it’s exciting to, finally, be a part of this…


Did you edit the hotkey for 3D View > Rotate View? By default it’s pressing in the middle mouse button and dragging. I use left button selection and have no issues with alt+left click for loop selection.

If you’re just learning, why not get used to right button select? The left button option is like playing musical chairs - all the shortcuts move over but eventually one or two can’t find anyplace to sit. There’s only so many chairs/shortcuts: some of them are hardcoded into Blender, and some are reassignable from the preferences. So you can move them all over until you come up against one that doesn’t move because it’s written in.
If you understand what I mean and if I haven’t misstated the case.

Also this will have started a storm of controversy so expect this thread to be immediately taken over by the posters who simply live to have someone mention Left button select. I’m guessing six pages before the thread dies.

As DruBan suggests, you can easily edit keyboard shortcuts in Blender. I’m using “emulate 3-button mouse” and “left button select” myself and just assigned all problematic left button shortcuts to their corresponding right button counterparts:

I love you people :slight_smile: Why didn’t i think of that - i know about the keyboard/mouse shortcut customizations. I was probably just ‘thinking too hard’ in my trying to get it all right :slight_smile: Anyway, thanks @Vaskania. I WILL learn this program! I’ve already mastered everything audio, but this, THIS, seems so daunting …and i thought music was hard.