Blender won't start

I try to open blender but it just flashes the cmd and the grey startup screen before automatically closing. I tried completely removing it and reinstalling it about 5 times. Please note that it works on my other computer which has an Nvidia card. Also I tried running it from the laptops HDD as well as my portable HDD and it closed both times. If someone can tell me how to check the log I’d be happy to post it.
OS: Windows 7 64bit
Blender: 2.72b 64bit
CPU: AMD Phenom II P650 Dual-Core
GPU: ATI Mobility Radeon HD 4200 Series
Also, I enabled the AMD gpu for cycles through the cmd and was using it for a couple hours before this started; I thought that doing a complete re-install would fix it but it didn’t.

Hi, may your startup file is corrupted, try to start with “blender.exe --factory-startup” in CMD.
If this work, delete your \2.72 folder.
I think it is in your User directory on Windows.
This directory include \cache, \config, \scripts and is not deleted during re installation.

Cheers, mib

I know the file folder you’re talking about and I’ve deleted in one of my other attempts but this time I can’t find it! :confused: Starting with “blender.exe --factorystartup” didn’t work.

That folder should be under
C:\Users\your_username\AppData\Roaming\Blender Foundation\Blender\2.7x (whatever your current version number is).
Delete that and Blender should start with factory defaults.

BTW, the command line expression mib2berlin mentioned was “blender.exe --factory-startup” (mind the hyphen!), while yours is “blender.exe --factorystartup”…?