Blender-Xatlas v0.0.6 Lightmap Unwrapping and Packing

Hi all,

v0.0.6

  • Added a Linux Build (Tested on Ubuntu)
  • Added 64-bit Windows build
  • Added an an Atlas Layout option for UDIM
  • Added an option to pack your current UV’s (may be buggy as I attempt to triangulate then restore the original faces)

None of the current unwrapping/packing solutions were giving me what I needed for my lightmaps so I looked at integrating Xatlas as an addon.

Blender-Xatlas is incredibly hacked together but I’ve gotten good use out of it, compared to other unwrapping/packing methods when it comes to lightmaps.
Any feedback is really appreciated, I’d like to bring it up to an acceptable standard.

Make sure to try it on a small disposable scene first to get a feel for it!

Sponza


Default settings for 1024px lightmap (no realtime lighting)

Standard Pack/Xatlas Pack(Note: attempts to maintain relative UV scales)

You can get the latest Windows/Linux version from:
Blender Xatlas Github

Thanks!

10 Likes

Looks like Xatlas make an auto-seams when seams aren’t manually provided? But how much stretched the islands turn out? Packing aside, it gives acceptable results with props/vehicles like assets?

Yes, it unwraps the meshes. Xatlas itself can pack your manual uvs but I haven’t added the option in Blender-Xatlas yet. With basic settings stretching should be limited.

For lightmaps I think it gives acceptable results, definitely better than any other form of automatic unwrapping I’ve found.

I’ll work on making more examples, but here’s a quick one:

2 Likes

It’s great that you have implemented xatlas in Blender. Certainly shows some significant improvements over things like SmartUV on some of my models.

Unfortunately it fails on many of my models. They are imported from Revit, so the meshes are quite messy, but SmartUV manages them (slowly).

I realise you may not be working on this any more, but if you are then perhaps I could send you a sample model so you could see what is going wrong? It isn’t your problem, so no reason why you should, but if interested then I would be happy to share.

Hi,
I’d be happy to look at it.
There’s a few areas I could see failing, I just never came across them myself!
Anything that improves it is always appreciated.

Well this a major upgrade from the default auto UVs, just the packing option alone is super useful.

Quick test:

The only problem I had was with the x64 build (im on win10-64), xatlas.exe was just not working for me, but the x86 did the trick.

Thanks!

Hi,
I’m using x64 build on Windows 10. If you have the opportunity could you see if it gives any errors in the console?
If not, no worries; I’m just glad one of them worked for you!

1 Like

It was because I had an old Microsoft Visual C++ 2015 redistributable, now it’s working :slight_smile:

1 Like

It gives really bad results on complex objects maybe I’m doing something wrong.

Hi trojenM,
Any chance you could send me a model that gives you those results?
Also what Blender version are you using? 2.93 has given me some odd results I haven’t looked into yet.
Thanks

Im already install but this addons not appearance in addons menu,i use windows 10 and blender v2.91,addons version is 0.0.6 and 0.0.7.please help me because I need this addons for the lightmapper.thanks

Hi skyzzz,
It’s working for me on Windows 10 and Blender 2.91. Are you using blender-xatlasX64.ZIP?

It should appear here once installed:

Hopefully I can narrow down what’s going wrong!


Thanks for reply,Yes im already install it and x86 but still not working.i try install previous version 0.0.5,it work and the tool is appear.if i install v 0.0.6/0.0.7 the tool is not appear

So if you install from the zip: 0.0.5 x86 appears in the addons menu, but 0.0.6 x86 and 0.0.7 x86 do not?
Would you be able to open Window > Toggle System Console before installing and see if it shows any errors when you try to install?
I’m having a look through to see if I changed anything that would be a problem between the versions.

Edit: I just had a look and that’s when I switched to automated builds, previously the zip had a folder called blender_xatlas containing the files in it, now the files are at the root of the zip. I’ll see if that’s the problem.

yes.both x86 and x64 in 0.0.6 and 0.0.7 the tool will not appear after install.but 0.0.5 x86 work fine.there is console when im install the version which you upload

Thanks for that, it looks like it was my fault. I was under the impression that the files should be in the root of the zip when they should be in a folder.

I’ll update on github, but if you give this a go it should hopefully work:
blender-xatlasX86.zip (116.1 KB)


Thanks :pray: ,now it worked

Glad it works, thanks for reporting the issue!