Blender3D Crashes at Startup

My problem is that when I run Blender3D the usual console will pop up stating the usual Python check.

After that, the Blender3D window immediately opens but before anything is displayed the window is immediately closed.

To remedy this, I would simply reinstall the application. It will work fine until the computer restarts. I’m guessing that it has something to do with changes be done, but I am completely clueless as to what happens.

So, I ran Blender in debug mode and this is what I receive:

Hopefully someone is able to tell me how to resolve this issue.

Emmanuel Barroga

Have you run other releases of Blender without problems on the same system?

If so, it sounds to me like this might be what you need.

If older versions don’t run properly, then it’s probably not a Blender bug. Seems maybe your system’s initialization process is somehow corrupted, given that Blender works when you first install it, but not after the system has been re-started.

I am assuming that you are correct because this issue has not happened before (previous versions).

This problem has also happened with Blender3D 2.46, which was the previous Blender version that I used before 2.48.

I guess my only solution would be to re-install the OS.

Just an idea. Before re-installing your OS, try re-installing the “Visual C++ Redistributable Package”.