Blotchiness from area light in interior rendering

I have an area light that is causing these artifacts to be all over my scene. It gets worse the longer (more samples) the render goes. The area light (settings below) is outside the glass doors on the left side of the image.

Render Issue Light

I thought it was denoise at first, but it happens with it turned off too.
I have set the clamping for indirect lighting at 0 and at 50, with the same effect.

Any ideas what I can do to fix this?

Here’s the image with area light turned on:

And with it turned off:

It looks like an issue with your normals texture, IMO. Have you tried tweaking the distance / scale / strength?

The wall has a bump set really low at 0.050. I unplugged the bump node and it did seem to help the issue, but it eventually happened again.

Here’s the rendering at 50 samples with the bump node unplugged (on the wall only):

And here’s the same rendering at 155 samples:

I’m seeing a severe artifact also on the floor that looks like displacement. Also, on the upper left wall, it looks as if the same texture is affecting the roughness value.

Yeah, I agree it does look like that could be the issue, but here’s a rendering at 472 samples with the bump map unplugged from the walls, floor, and the concrete wall outside.

And here it is at 1672 samples. It’s getting better. Maybe this scene is just more complicated than I’m used to and needs a ridiculous number of samples to appear resolved.

By the time I got this all typed up, it finished the viewport rendering up to 4096 samples. I feel like no matter how many samples I go to, it’s still going to be an issue.

The floor is still looking a little weird, unless that is a shadow.

Can you share the project without the furniture and other filler objects? Walls, floors&ceiling, doors&windows, and that lamp should be in there. Make sure to purge anything unused to limit the file size. Also be sure to test that the problem still exist at that point. 1000W area light and clamped seems senseless to me, but it’s really hard to guess with only images to look at.

The color space of the displacement map is set to sRGB, and this messes up the color of the wall. Any map other than diffuse/albedo must use Non-color as its color space.


does it still happen with the glass doors? try removing them. how is your glass material setup?

Check if you dont have overlapping meshes or objects. Check UV of wall. Check displacement modifier and nodes. Disable denoiser. Check light path settings.

Thanks everyone for your help. I was able to resolve the issue by increasing the strength of the HDR background and lowering the power of the light to 400W.

I am still curious as to why this was happening and if what I did is the only way to resolve the issue. I’ve uploaded a stripped down model that still has the issue in it.

I played with turning off the glass door on the left and it didn’t take the issue away.

IMO your artifacts look similar to some roughness maps I have seen. I wonder is that is a factor.

In scene you uploaded, the main walls have metallic shading. This is a very difficult scene for Cycles. Maybe you could improve it by deactivating the noise treshold and setting filter glossy to 1 (haven’t tried, would take a long time to render).

The other thing they remind me of is before we had proper emission, we used “radiosity”, which was a whole other protocol, and it baked everything into your object as vertex colors after massive subdivisions. I have no idea what caused it, but it makes me think it might be related to your emitors if you are using emission.

I had caught the metallic setting being cranked up to 1 on a lot of the materials. For some reason it was defaulting to that. Changing it didn’t affect the rendering issue though. I did try disabling noise threshold and setting filter glossy to 1. That also didn’t fix the issue.

In the blend file I uploaded, all texture images have been removed and the issue is still there. To light this scene, I have a few area and point lights. They aren’t set to “emission” material type (nodes aren’t being used for the lights), but I assume it’s a similar or the same protocol. It’s definitely the area light shining through the left sliding door that’s causing the issues. Just not sure what to do about it!

You should try using a large emmitor, which is a similar effect as an area lamp. You just set an emission value in your materials, on a squashed sphere or something like that, and if the object is in the visible scene, go to object buttons >> visibility >> ray visibility and uncheck “camera”.

Its the glass material.

With Glass:

With a “fast glass” style replacement (2 options in the shader editor, pick whichever works better for you)


Is there a Sherlock Holmes Award?

In the top example I do “facing → power 5 → add 0.05” with no extras, and you get “fresnel” shadows from the glass too. For thin geometry based glass, you need to do 1/IOR for backfacing faces fresnel. I always use the cheap version though, no complaints so far.

Showing none instead of sRGB to show how close the fresnel and “fake fresnel” really are.