Bmesh modeling issues

Hello guys, I’m trying to refine a shape that I quickly made with some boolean modifiers, by adding vertical and horizontal cuts.
basic shapes with booleans.
Then I want to refine the mesh by addin detail. This is a new way of modelling for me.

I don’t see any way the knife tool lets me just make a straight horizontal or vertical cut. I can use the C button but it only works on the view. If I go into side view or front view the knife won’t snap to the “corner” vertex.
I’ve long been able to keep working without new bmesh functionality. Trying to get up to speed, what I’m asking for seems pretty basic. Can it be done?

Imageshack only showing tiny pictures in your post! Blender version no.?

Never mind I see it’s 2.71 you have to dl the image to see it!

If you are constraining the cut you can’t really expect it to snap as well because that would deviate from the vertical or horizontal direction, no? Have I misunderstood you? You may be seeing the problem of prspective view combined with constraint, switch to ortho view to see it make the cuts parallel to actual vertical and horizontal axes. (If you are in an axial view).

Does that help?

Yeah, imageshack used to work nicely, not anymore… just made a new account for it. Unfortunately, no that doesn’t help. I can’t get the cuts in orthographic or front or side view either. All I want is to be able to cut from a vertex, straight up vertically or straight to the left/right horizontically. In really older versions of blender (2.49 I think) you could do this by just making a temporary line where you want to cut, select what you wanted to have cut, and then snap the knife tool to the vertex on that temporary line using ctrl. Would be awesome if something like that was available with Bmesh as well. Or if somebody knows a better way to do it. Right now I’m messing around with booleans to get the desired results… very messy and cumbersome way of doing it.

You’ll have to explain better what’s failing then, because this is a standard behavior with the knife. Just press C once, don’t hold it down or anything. Watch the header for the status of the constrain. pressing once will toggle it on and off. I was able to make complicated series of self intersecting cuts at 90 45 and 180 etc degree constrains with no misses.

I tried to say earlier that the knife tool is view dependent, it does not know anything about the world orientation or anything. So to get a cut aligned to world horizontal or vertical you have to be in ortho view and one of the axial views, front top right etc. And it might be a problem that you can’t switch views with the shortcuts once you start the knife, but you can MMB drag and then hold down the alt key to snap to views even when in the knife tool mode. So really there should be no restriction on any cut you want to make.

You should also watch out for using the shift MMB drag to pan the view; this will toggle the snap on and off with each press and you might wonder why it’s not snapping. Once again check in the header id something isn’t working right for options that toggle on and off.

I’m probably doing a few things wrong then, can I send you the model somehow to take a look? One of the issues is that I can’t seem to snap the knife to the vertex I want to start from in side view, because there is geometry in front of it. Another issue is that if I try to cut that way, I have no control over which faces, which are overlapping only in view, get cut.
I managed to cut straight up in orthographic view, instead of perspective. That worked, but unfortunately, it’s not nearly enough.

Shift K will invoke the ‘selected only’ knife, which will ignore any geometry that was not selected when the tool was called. This is most effective with the ‘limit selection to visible’ option OFF as this will let you see through the geometry that you are not cutting.The ‘selected’ knife is a great help when you have concave forms in your object.

Or you can select what you want to work with and shift H to hide the other part (alt H to show it all again).

You can upload a model here or to if this does not resolve your problems.

sometimes it seems to work, other times it doesn’t. Here’s what I have so far (mind you, it’s messy) I’m trying to find a bmesh workflow that works for me, instead of relying on endless boolean modifiers,applying and merging.

Okay that came with just no information at all. Minimal info is par for the course here but I think this is pretty extreme. No idea what is supposed to be done with the file. Boolean is not a good tool for this simple stuff.

Here’s a guess at what you might need. Please accompany files and suchlike with some sort of verbal assist. I don’t see any connection between the description you gave previously and this model. Vertical cuts where? Horizontal cuts where? Sorry to be of no help here but GIGO, right?

Your statements are vague - ‘trying to find a Bmesh workflow’ doesn’t say much, and since Bmesh is entirely behind the scenes there’s no point in mentioning it in this context.

(Edit: I’m assuming you’re not a little kid but if you are then carry on, you’re doing fine, and sorry to be so harsh!)

Some more examples FWIW. You really need to understand what nonmaniflod means and why it’s a problem. Just throwing in geometric blocks and trying to glue them together with Booleans and other methods creates such bad geometry that the time it takes to fix it is many times what it would take to remodel it properly.

Please put Boolean modeling and concepts like Bmesh out of your mind and focus on elementary modeling using
1.constrained translation and rotation,
2. loopcuts,
3. edge slides,
4. Extrudes and insets.

Almost everything can be modeled this way. Even the knife tool is meant to supplement these basic skills, not ever replace them.

It may look like you are adding lots of unnecessary lines but they provide much better and more editable geometry. Your model as it is is a disaster; it has verts that sit on edges without being connected to them, internal faces, intersecting faces, overlapping faces, concave polygons etc.

This picture shows some methods of fixing the model but I don’t advise it.

While at - there’s always several ways to deal with cats…
I always feel funky using Bisect - like carrying a plywood in the wind :D, so here’s what i do:

  • extend a bit roof temporarily so that it crosses columns
  • assign top vertices of columns to the Vertex group
  • add Shrinkwrap mod to the columns and set target - house.
    As soon as you add vertex group and set it to Project Z only you have all needed fine tuning control.
    Apply Shrinkwrap, delete 2 vertices on roof.

So here’s how you should really be modeling this. Start with a cube, Add a loopcut, drop the roof eges add more loopcuts where there’s going to be walls etc. Then you might have this.

Now delete vertices and edges as necessary, and make faces where you’ve made holes by carefully selecting four edges or verts and hitting F. Add loopcuts as you go where they’re needed.

You can get to this next pic from a default cube using nothing but loopcut (ctrl R), edge slide (G, G) , delete vertex or edge (X), and make face (F). Construction is still all quad, all manifold. It’s what you should be shooting for ALL the time.

From here on in gets a little more complicated, and I don’t really see your plan very well so I’ll stop.
Pitched roof buildings pick up triangles easily, but you can practice your quad construction skills ( and triangles are not that bad in architecture anyway).

Tinycad VTX addon will be very useful for precision modelling (Cross Section of 2 edges).

I also use Zmj100’s: