Bone is parented but weight paint mode shows otherwise?

Hello All,
Newbie here trying out my first human model/armature. It’s going really well so far, my rig is working as expected except for one aspect.

The femur bone, despite being parented and having the same settings as each and every other bone in the armature is not deforming the mesh. In fact weight paint mode shows it as a non connected bone (whole model is purple see screenshot below)

Heres what my link and bone settings look like.

The shoulder bones (which are similarly disconnected) are set up in the exact same way. So why can’t I weight paint/deform from this bone? What am I missing?


Okay so odd but I fixed by literally just selecting the bone and assigning automatic weights from the bone again. I think I may have initially had deform unselected for this bone before parenting the model to the armature and I guess selecting deform afterwards doesn’t recalculate weights? Could be a bug, could be a feature, I dunno!

Hi, can you attach the scene file?

It is absolutely not a bug. If it wasn’t set as a deform bone when automatic weights were applied it doesn’t magically get vertex weights added when you change the bone’s deform setting later. The program should never be making changes that you didn’t ask for. Automatic weights are just a convenient, crude starting point for weight painting. Say you’ve put in a lot of work getting vertex weight tweaked to be just right, and then… something changed, and blender decides to recalculate your weights. It just doesn’t make sense.

It’s not a bug, it’s not even a feature, it’s just the default way it works. By default it shouldn’t stomp on your work if you don’t ask it to.

You’re right actually SkpFX, my understanding of what purple signified was wrong was the real problem. I had been told that purple meant that the bone was not able to effect the mesh and therefore could not be weight painted when in reality purple just meant the bone currently has no weights assigned.

Believe it or not I didn’t actually try to paint weights on there otherwise I would have realized my error, it all clicked for me actually after I read your post, I went back to my model and tried to add weights to a purple vertex and of course…it worked! Some things ya just gotta learn the hard way I guess.

1 Like