Boolean difference operator in Blender 2.40

I have a problem with the Boolean operation ‘difference’. Two closed objects are given. In the first one there is a cylinder with 146 vertices (24 segments, in 6 levels). It is the base object. In the difference object there are 58 UVspheres with each having 18 segments and 18 rings each. So we have a lot of vertices here (17864). The second object is penetrating the first one (each UVsphere penetrates the cylinder in the same way).

I used Blender 2.34 and I received a result object in about one minute. Unfortunatelly it has some errors, but with 30 minutes of work I could fix them by hand.

Now I am using Blender 2.40. Here the process takes a lot of time - nearly one hour - and finally no result appears. With a testing object having 4 UVspheres as difference for a cube I get a result but it takes some minutes.

Does anybody know if there was a major change in release 2.40 in this function? Is this a known problem or do I habe to do it in an other way. Please give no solutions like “there are to many vertices” - the older version could do it.

Thanks, Matthias

Yes, boolean functions have been completely reworked. Seems they need some more work on them.

does it behave similarily as a 2.4 modifier?


I selected both objects and used the w-key in order to apply the difference operation. This was the way I was used to it. Toni informed me that I should take a look to the introduction of the modifier system. Unfortunatelly I could not receive any result this way, too. The error message was:

Modifier is disabled or returned error, skipping apply.

On we can read

Boolean Modifier
[…] It should be noted that this code currently uses Blender’s undeveloped boolean system and that a much cleaner and more stable booleans system is in the works.

I wonder why the described error occurs because they talk about an “undeveloped boolean system”, but it seems that that some changes took already place.

So my work around is to use a previous version. Some postings document the problem in the bug-tracker already. I am sure that the developers will solve the problem.

Thanks a lot for everyone giving me an answer. Feel free to add any comment or better solution.


Yes, you’re right. It’s already the new boolean system, these last minute changes … one can’t keep the docs up to date :slight_smile:

So I posted the problem to with the description and a file to check it out.


You could always try the “megabool” script and see if that works any better for you.

I had the same sort of problem about a month ago. Another kind user solved the problem for me. Here’s what he told me to do: first > select both meshes and remove doubles, second > use the decimator tool on both meshes until you get an acceptable result, third > run your boolean operation. This has worked really well for me in 2.4 with no problems so far. I like it a lot. Hope this works in your particular case.

Didn’t you try the 2.41 release?

EDIT : I did it myself with the file you posted in the bug tracker. and it doesn’t work no more

Finally when Isaw what you were doing, I think you can get around the problem, I’ll try to do it when I get some time, and post it.