Boolean modifier - disabled, skipping apply

Hi all. I’ve googled this and looked in here with no luck so far. Although I get a number of hits with this error message, none of the threads or docs so far has been of the least help. I’m using 2.70 on ubuntu trusty. I’m getting this error whenever I attempt to apply the boolean modifier in any mode, on any meshes, under all circumstances. That means exactly what it says. Before anyone says “check your mesh”, or “try a couple of default meshes”, or “restart blender”, let me say that I have tried all of these and many combinations thereof. Nothing works. It cannot possibly be that I’m doing something wrong that’s different each time, in every different case – the odds are infinitesimally small that this is the case.

According to the 2.6 documentation:

“…and when the modifier cannot be applied to the mesh, Blender will show the message “Modifier is disabled, Skipping Apply.”. In this case, you either have to remove some modifiers or apply the necessary ones.”

This is utterly useless as information. Besides, in all cases mentioned above that I have tried, it is the only modifier applied. This is like saying “it doesn’t work because something is wrong somewhere”. C’mon, man. Who wrote that, somebody who works at Microsoft?

Anyway, now that the rant is over (I feel better) can someone somewhere on here please let me know if this is a known bug, if there is anything in the settings that I can try to apply, etc etc etc… ? I really would appreciate it very much. Thanks in advance!

Solved for me. As usually is the case, I have to make an ass of myself before I find the answer. I WAS doing something wrong. Let me put this into a step by step for the benefit of others in the future:

  1. Select ONLY the mesh to which you want to apply the modifier.
  2. Under modifiers, select boolean.
    – Now here’s where it went right for me –
  3. Select which modifier “mode” you want (difference, union, intersect)
  4. Select the mesh which you want to use for the modifier FROM THE DROP DOWN LIST – DO NOT SELECT IT IN THE 3D VIEW WINDOW!
  5. Apply. (if you selected the “Difference” modifier, you’ll need to either hide or delete the mesh you used to create the cut before you see the result).

My apologies for the rant in the original post.

3 Likes

thank you!!

Excellent. Thank you.

thanl you so much! it did worked for me on 2020! big hug! :smiley:

I have tried following this, but I do not get an apply button. I am using Blender 2.91, and am experienced with Blender and the boolean operator, no apply button appears. There should be a way to do this in Python, but I am not finding it.

Since 2.90 Apply for modifiers is no longer a button, it’s been tucked away into the small dropdown menu:

image

…which you don’t even need to reach for as you can just hover your mouse pointer over the modifier and press the hotkey.

Wow, seems a bit strange. I discovered there is also a boolean modifier in the plug-ins and was using that, now I will have to go back and find the line of code it generates when it is applied. Thanks!