Boolean Modifier issue

I seem to have no end of issues when it comes to modifiers. I want to believe that I’m just doing it wrong, but when I’ve used it before and it works and all of a sudden it doesn’t after updated to the latest build, one can only wonder.

Anyway, I’m trying to use the Boolean modifier to put holes in a mesh but all it does is wrap around the object. What exactly is going on?

Looking at your screen shot the problem seems to be that the wall has no thickness to it. Boolean modifier works on 3d objects while your wall is completly flat. I can’t be sure though there is not much to see on your screen

Boolean does work for flat surfaces as well, Jerzy. What you want to do with booleans is use one object at a time to cut a hole, then apply the change and remove or move the object you cut (or any other type of operation) with. If you don’t move the object it looks like nothing happened, could be the case here.

You have the modifier set to difference and not intersect.

Intersect makes the wall disappear.

Jerzy might be right about the flat surface thing, because after I add the solidify modifier it worked. Though I was expecting the cube to disappear, it still worked. I just had to make it invisible.

Actually, it does work on a flat plane, but what I had to do was add a couple of edge loops, without them there is nothing to the boolean to operate on, that’s why things vanish sometimes, it acts on the whole object. But for your purpose, it only makes sense to add the thickness modifier instead of loop cuts or extrudes, both of which will work. This all as was stated using difference, I know I have used intersect before and got the same result, but I could be wrong.

Simple planes with couple loops and an extruded plane all with a boolean difference.