Boolean modifier leads to fragmented/subsurfed meshes


#1

Hello Blenders,

I recently moved to a new machine and moved my old blender installation with me. I just use it to create simple models for 3d-printing, so my knowledge is good for that and little else.
On the new computer, I encountered an interesting problem: after applying a boolean difference modifier to the cone, the program created many new polygons in the mesh:

On the old machine, Blender behaved and the same operation yielded ONE cleanly cut new surface which I can work with.

I suppose I somehow disabled this mad cutting behavior on my old machine and I look forward to doing so on my new one, but I am lost as to how to do that. Can anybody give me a hand on that? I assume it is some simple hotkey, which I just dont know.

Also, I apologize - the topic was probably brought up a million times before, I rummaged through the forum, but since I cannot name the phenomenom, it is hard to find a lead.

Thanks in advance!

Chris


(3DKiwi) #2

Not sure but this could be a graphics card / graphics driver issue where the hidden N-gon edges are being displayed when they shouldn’t be. Make sure you’re running the latest graphics driver.

What’s the GPU on the new computer?


#3

Hello Kiwi,

its a GForce GTX 1080.

Highly interesting comment, I upgraded the driver and rechecked whether I was just seeing things that were not really there.
Unfortunately, turns out the things ARE there and they are real polygons:

Gives the whole problem a new direction though. I was convinced that I was just missing a hotkey to make Blender behave again. Think it could be a hardware issue?

Sincerely,

Chris


(3DKiwi) #4

Weird. No matter what I do, I can’t recreate this. Doesn’t seem to be a setting in Blender to hide N-Gon edges. They seem to be always hidden.

So when you create the cone do you get the triangulation on the bottom?


#5

No Sir. A freshly created cone starts out without excessive segmentation. The additional polygons appear only after I applied the Boolean. Even those on the bottom. Which is interesting, since that surface was not even remotely touched by the Boolean.

Sincerely,

Chris


(3DKiwi) #6

Have you tried doing a clean install of Blender? i.e. uninstall then go and delete folders etc not removed when you uninstall. Something is definitely not right.


#7

I tried that today, reinstalling 2.65. No progress.

However, at that point (I totally agree with you, something is not right), I got around to install 2.78 - 2.79 was also tried but would not start - and voila, now I can Boolean meshes unpunished. Yey!

I hesitated to do that, new version and all that and I thought I was just missing a hotkey. But since you confirmed that there was something amiss, it seemed to be the right step.

Thanks alot, Kiwi!

Sincerely,

Chris


(3DKiwi) #8

Yay!! Glad you’re up and running again.