Boolean Problem

Hi, I am trying to create a hole in the beehive using a sphere. I converted the beehive into geometry from a spline object (alt C). I then selected the beehive and added a “boolean” modifier (difference) and selected the sphere. But when I try to hide the sphere in the sphere doesn’t hide (see 2nd. image below).

I think it’s the beehive object. because I did a test. I created a cube and a torus. I then used a boolean object on the cube and I could delete the torus.

So is there a step you need to do to an object after you convert it from a spline into geometry (alt C) but “before” you use a boolean modifier on it?

Check the normals on all objects involved: All pointing outward? The sphere looks suspicious.

Yes Normals seem to be correct. :frowning:

When I select the "Sphere’ as the difference object it turns a darker grey. This isn’t normal is it.

May we see the file?

Sure I’ll pack it up. Strange. I created a default cylinder and the boolean worked, but as soon as I scale or rotate the cylinder it turns darker grey and it won’t work as a boolean object. Frustrating.

Heres the file. Thanks.

Have a look at the beehive in wireframe view:
You have all kinds of internal and overlapping geometry where the different “levels” meet on the outside (Solidify modifier?). That’s too much for the Boolean modifier to handle… And that’s why your cylinder example works fine, as it does not cut through the problematic areas.

Delete the rim and the outer hive polygons (they’re the ones causing trouble). Then do the Solidify again - but to the inside (negative values) - that way it’s easier for the Solidify modifier to avoid overlapping geometry.

.blend (ZIP, 234 KB)

Hi, thanks. So I am not sure I understand what you mean by:

“Delete the rim and the outer hive polygons (they’re the ones causing trouble).”

  1. I removed the “Solidify” modifier.
  2. I then converted the spline to geometry (Option C). The geometry is clean.
  3. I then added a “Solidify” object and “Applied” it.
  4. I then added a “Boolean Modifier” to the mesh object.
  5. It works.

Can I ask you, how did you keep the mesh so clean/crisp? The hole doesn’t look clean like on your mesh. (see render below)

In the file you uploaded the Solidify modifier was already applied. So, to get back to the “base bee hive” I had to delete everything that was added by that Solidify modifier, which were a) the outer hive polygons and b) the upper rim between outer and inner hive.

To get the hive sharper either add an Edge Split modifier or check “Auto Smooth” (better option) with a low angle in the hive’s object settings:

You might have to enable smooth shading on the cutting sphere, too, as this will influence the shape of the Boolean cut.

Wow, didn’t even know about that smooth shading feature. Thanks for all your help Ikari! :slight_smile:

You’re welcome.
If I recall it correctly, Auto Smooth was not available for Cycles for quite some time and has been introduced on the quiet around Blender 2.70. I would guess that quite a few people don’t know about it and use the Edge Split modifier instead.