booleans do not work in 2.40

I just tried the new booleans in 2.40, but the only thing they do is giving me an error message saying:

Error: Modifier is disabled or returned error, skipping apply

. Has someone else the same problem? Is this a bug?
I am running on gentoo/linux with a self-compiled Blender and gcc 3.4.4.

Help is appreciated and thanks in advance,

is it a closed mesh?

also this should go into the blender general forum i assume.


Yes, I tried it with just two simple cubes, and some other objects too, but none worked. I have no idea what the reason could be.


a self-compiled Blender

Maybe that’s where it went wrong? Are you sure you compiled it correct? I haven’t seen this problem with the official builds…

You have to be in Object mode, select both meshes, press w and choose boolean type.
Move both meshes aside because there is third one created as the result.

I have to say the booleans are just as poor, if not worse than they were in 2.37a, I haven’t really seen much to indicate they were done any better. Even the simplist of booleans are failing for me to create anything near a clean mesh.

What I mean is, they still need work… :wink:

For example, I cant get a cylinder and cube to boolean union correctly at all. They kind of cut into eachother, but do not actually join. Other times I try differences for fairly simple shapes, (boxes into boxes) and get very strange cuts.

The booleans seem broken in all optimized, 2.41 alpha and orange builds (in the Win binaries I tried)… Using a simple UV sphere and cube union causes to crash all of them. Except the regular 2.40 version (and ZanQdo Orange build), which works fine…