Border select (B) doesn't work properly on Ubuntu linux

Well, the problem is that when I press B to make a border select or a circle select (B pressed twice) it doesn’t updates at real time…i can select but the circle or rectangle does not follow my mouse, only when i have the LMB pressed…dont know if you understand what i mean…

Any solutions?
Sorry for my english. Thanks

I really do not know what is happening, maybe is just a mishap on that version of your OS or kind of certain incompatibility of blender + ubuntu. it is the first time that you install blender on ubuntu? or it happened recently, (your problem)… try reinstalling it… that’s what i would do… or install a newer or older version of blender to see where’s the bug, by the way i think that ‘B’ is for “Box select” not “border” well, it is irrelevant…

Ubuntu and blender work fine together. What video card do you have and what driver is loaded?


I’ve tried blender 2.42 from the ubuntu repositories and the i’ve tried the 2.42.2 from CVS but i’ve always the same problem.

My ubuntu version is Edgy Eft 6.10 and i’ve the nvidia 96.31 drivers on a nVidia 7900gt
This is really annoying and i dont know why is happening…

The ALT+B shortcut does the seme thing…the mouse goes slow slow slow…
In windows works fine…so i think it’s something with OpenGl config or something…

Any solutions?

Can you post your /etc/X11/xorg.conf file? This is probably where the problem lies.


You didn’t turn on the desktop effects did you? (desktop on a 3D cube, wobbly desktop effect, scrollable desktop changing, etc)

These desktop effect causes your Blender to lag behind.

Just a guess and I’m probably wrong, but anyhow, try disabling the desktop effects in your Ubuntu to see if it helps.

Thanks Wolf it was that…when i turn off beryl it works fine…
Otherwise, is there any way to work with beryl activated?

How do you turn of beryl?

This looks like a 4 year old thread someone zombied, but for what it’s worth, I’m using Compiz now (successor to Beryl) with Blender 2.49 on Ubuntu and all is well, even with all the 3D desktop effects turned on. It’s actually pretty nice to have it running in its own side of the desktop cube while other surfaces have coding stuff and whatever on them.

First to comment 4 years ago, last to comment now hehehehe