Box Rendering Over Smoke Simulation

I have been able to create the smoke simulation I want (judged from preview), and when I go to render, there is a box covering the entire area of the smoke. I tried looking online, but everyone says to change ‘density’ in ‘material’ (which I cannot find and there is no material on the domain, which is creating the box in preview). I am confused as what to do , with nothing online helping (I have been tried several online tutorials/videos, but nothing there helped).


There’s even more obscure things for us in your explanation. Is this Blender internal render or Cycles? What produces smoke in your scenario - letter mesh or particles you generate on this mesh?
Why can’t you find out from tutorials online that domain contains equally thick smoke material and particles or texture you see in smoke preview is what defines thickness of the domain material which is then visible in render? (Domain without appropriate material is rendered as an object having default material, like in your images.)

You could - in a new file, default scene with a Cube in object mode selected Space search “Quick” - Quick Smoke example will let you explore materials for the renderer you have chosen.

If this still does not help - delete all flying debris, leave domain and blender’s default “Text” instead of your logo, use option “Compress” while saving example file, upload and post a link here.

Have you read the “ink drop” tutorial at BlenderDiplom?
Perhaps it has some tips that may solve this for you.