Box select-Hide-Stopped working?

A few hours ago I could do box select + H to hide part of my model but now it has stopped working.
I can select the whole model and Hide it but I cannot select only a part of the model with Box Select.
Here is a screenshot showing different colors when selecting which represent the problem I think however, I don’t know what they mean or how to clear the problem.
I am not aware that I changed anything since all was working well, a few hours ago,.

Please could someone give me some clues or an explanation.
With thanks.
/media/WOS14GB/Screenshot at 2020-04-04 23-42-16.png

An hour later and I have found out what the colors mean and have been trying to compare several copies of the same file. One of them worked perfectly, but a second one did not!.
I then went back to the file I had the problem with and ‘‘sod’s law’’ that worked as well!

I write down notes all the time (old head) so I know what I did and did not do and now I am wondering if this might be a possible hardware problem, because – I am running an Nvidia Quadro K420 which is only just capable of running this 4K monitor although System Monitor shows all 8 processors working easily and only around 8GB of RAM being used (of 16GB).
Any thoughts/suggestions would be much appreciated.

I need to solve this problem before I can continue with my model and here is what happened today.
Started Blender and imported a .obj file into a fresh blender.
Box select part of model and hide and it worked OK. Great!
Hid the object and added a plane.
Unhid the object, went into wire frame mode, and now box select will not work.
I position the box, and as soon as I release the LMB the whole object is selected.
Everything else is working just fine and I cannot find any clues or answers by doing web searches so I am really stuck unless some kind person can give me some clues.
Edit: I wondered if it might have been caused by a modifier so I started a fresh blender and opened my original object and I have the same results.
The only common denominator I can see is that if it does hide the part I have selected, it never hides it completely, there are various vertices and edges left showing and always in different places.
Total frustration.