Boxcutter: Pressing Enter moves & changes the cut shape


In Boxcutter, and with Cut selected, when I press “Enter” on the keyboard to lock-in the cut, the shape of the cut as well as the location of the cut, changes on the object.

In the attached picture, the thinner rectangular box is my created cutter, but the highlighted square is the result I get (it’s in the wrong position and a completely different shape). Does anybody know what’s going on? Is there a setting I have turned on somewhere that’s making this change? I want to say it has something to do with the Origin, but my settings seem to be mirroring what other users have in Boxcutter tutorials I’ve been watching.

Wild guess: is scale applied?

Thanks for the reply. I scaled the object as suggested, but now, when I attempt to draw a shape in BoxCutter, Blender crashes (oof!). So I need to solve that issue and then I’ll give it a try. Thanks Okidoki!

Ugh, I uninstalled/reinstalled Boxcutter and HardOps and now it doesn’t crash, but the issue still persists. I cannot cut any shape of any size. When I press “enter” or double-click my mouse to lock-in the cut, the shape I draw changes, and no cut/slice/inset, etc, are created. The only things that are created are two new box shapes I need to delete. Also, the attempted cut creates a duplicate of the mesh I’m trying to create (Please see result of attempted cut below) Boxcutter shrinks my intended shape and pushes it to the top left corner of the larger box and creates a duplicate. A lot going on there. Is this a bug, or do I need a newer version of Boxcutter? I cannot figure this issue out for the life of me :frowning: P.S. I’ve tried cutting, slicing, insetting many different primitive shapes and I get the same result.

Boxcutter exists for a while now and i don’t think that nowbody would have found this all buggy… and an actual version (blender/boxcutter) is a fundamental prerequisite before talking about bugs (reading the docs and having used the tools begfore to detect changed behaviour also). I don’t know about overlapping cut objects in Boxcutter. You may even provide a blend file so that someone with Boxcutter (version?) can test this.

Hello, when attaching a blender file, do you just mean the documents I’m working on? Unfortunately, this website says “sorry, new users cannot upload files”

You have to spend some time (minutes not hours) in this forum to be able to do this (reading some articles and not just asking one question for example). If i remember correctly just following the tutorial introduced in you first private mail (click on your user icon on the top right and then the envelope icon) even shows you how and after this you already spend that much here… and yes the names file, record, document could all mean “structered data used on a computer”

Just to nit pick. ctrl a > Scale will apply scale. You didn’t say you applied the scale, you said you scaled the object.