Broken Ankle/Heel when parenting my model to armature

Hello Everyone:

I am a new blender user, who is still learning how to set a armature.

My Blender version is 2.71a,

I set up a rig like this, and I am trying go set my model to the armature.



I as learned in some tutorial, I know the bones work as CONTROLLER should be turn-off on the Deform checker under the bone properties.


(notice: the bone foot_R is under constraint under footControl_R, and so is toe_R under toeControl_R)

Mostly the parent relationship works fine, except the ankle/heel parts.
the shape of the ankle/heel change when the parent is set.


I turned off DEFORM of the bone “foot_R” & “toe_R” the correct shape is back , but the rig don’t work deforming the ankle/heel.

I am still working on this and not figuring out what is wrong.
Please give me your suggestions?

Thank you!

Hello and welcome to the forum!!!

First suggestion is to post up the .blend file, but since you are a new user you might have problems doing that. I think new users are slightly restricted until your post count hits a magic number around ~10ish… It’s an anti-spam measure. Normally, users here can attach .blend files to their posts, or post a link to an off-site hosting service. Quick way to up you post count is to provide feedback in the Works in Progress, Finished Works, or the Focused Critique sections of this forum, or there are a couple of games in the Off-Topic section… Anyhow, posting up the file allows someone to get in there and look around at the problem.

So how’s the rig work so far? No doubt you’re posed it to test that the feet bones are moving correctly, everything working smoothly? No flipping of bones? Enter edit mode for the rig & exit out of it, then open a console window and check for error messages. Errors with constraints/drivers are usually reported there. And turn on the bone axis view option in the armature properties panel. To me, it looks like your heel bone might be flipping on it’s y-axis 180 degrees, that’s why the bottom of the foot mesh is up around the bottom of the pant leg. So look at the heel bone’s x & z-axis arrows when in edit mode and in pose mode, are they pointing in the same direction? If not, then a constraint/driver is causing the problem. If the console doesn’t give you a error, then it might be a bit harder to find the problem.

Give it a try and see what happens,
Randy

just as Revolt says… Flipping problems are teh first thing to check…

an easy way to know which way your bones are facing is to turn ‘on’ the bone axis view…

select your Armature > Properties Panel > Armature Object Data(the little man Icon) > Display > check the box ‘axis’

now you can see the axis orientation on all your bones…

do they line up with their parent? are the turn correctly? are they facing the same way in edit mode as they are when you tab into pose mode?

Thanks Revolt and norvman for replying!

Yes, I think the problem is about flipping.
This is how the heel’s bone looked like.
In the Pose Mode, the x axis is obviously opposite to other bones’, even they are the same x direction with other bones.
(And of course, the toe bone as well.)


Then I tried to flip the bones with this problem.
Under Edit mode, in the menu I chose: Armature > Bone Roll > Recalculate Roll, and chose “Local X Tangent” to make these bones have the opposite direction to other bones in the Edit Mode.

It did make the heel/toe bone have the same x axis direction with all the other bones.
And the twisted foot shape is back to normal!

I am not sure if this the right way to fix it.
and actually the shape of the foot is still changed from the original:
(it how the foot shape look like in the Edit mode)



(And in Pose mode, the shape’s still changed a little, when I fixed the x-axis of the heel/toe bones as mentioned.)

Anyway, I think it might another issue about weighting!

How you guys think about that?
any suggestion or question are wellcomed!

thanks!

Attachments


when in edit mode… with a bone selected note that in your right hand tool bar under Transform… there is a “Roll” adjustment slider… you can slide it or click it to input numbers to adjust the Roll angle of that bone…

I don’t think this is a roll issue…

Do both the toe & heel deform bones in the feet have the same x-axis when in edit mode? Before you messed with the roll angle of that bone?

I’m thinking it’s an issue with a constraint flipping the bone instead…

Both of the bones, the heel and toe deform bones, should have matching x & y-axis in edit mode.They should also match in pose mode. Before your bone roll fix that is…

Attach the file and I’ll take a look…

Randy

when in edit mode… with a bone selected note that in your right hand tool bar under Transform… there is a “Roll” adjustment slider… you and slide it or click it to input numbers to adjust the Roll angle of that bone…

Thanks norvman

I tried to select the Roll adjustment slider under Transform of the Tool Bar as you mentioned. However I only found" Translate/Rotate/Scale", but couldn’t find “Roll”


I think it’s because I am using 2.71a

And I think is might be move under Armature menu under the Editor Memu.
Bone Roll>> Set Roll (Ctrl R)


Is that right for you?

Thanks again!

Hey Revolt!

Do both the toe & heel deform bones in the feet have the same x-axis when in edit mode? Before you messed with the roll angle of that bone?

Yes, They are the same x-axis. the following image indicates the way they were before I set the Bone Roll.


When this issue was found, I thought it might be about constraint setting as well, but could confirms this. I would be great if you could take a look of my file, but I can attach blender file due to my account is new. you might get it from this link (just updated!):

http://www.pasteall.org/blend/32253

Thanks!

Thanks norvman

I tried to select the Roll adjustment slider under Transform of the Tool Bar as you mentioned. However I only found" Translate/Rotate/Scale", but couldn’t find “Roll”

you must have a bone selected… and be in edit mode…


be sure your not mistaking the Properties Panel for the 3Dview Right hand tool bar…

Use the “N” key in the 3D view to get the Right hand tool bar to come up…

you might get it from this link:

http://we.tl/l361Dvl3iN

Thanks!

do us a favor and use pasteall.org
for file transfers… they have a special blender file transfer there that works great…

be sure your not mistaking the Properties Panel for the 3Dview Right hand tool bar…

Use the “N” key in the 3D view to get the Right hand tool bar to come up…

Cool, I got it, and I think it works as Bone Roll function does, doesn’t it?

And thanks for recommending pasteall.org, I update the blender file link here:

http://www.pasteall.org/blend/32253

Cool, I got it, and I think it works as Bone Roll function does, doesn’t it?

you lost me…

OKay… easiest fix for this is to replace your “track too” constraints on your
Foot_L,
Toe_L
and
Foot_R,
Toe_R…

with IK constraints… set to the same targets… but set the Chain length to “1”…

that will get rid of the flipping/ twisting…

OKay… easiest fix for this is to replace your “track too” constraints on your .
.
with IK constraints… set to the same targets… but set the Chain length to “1”…

That’s awesome. this replacement indeed fixed the problem.
I seems like the Track to constraint is the right method for such a bone structure.

Thanks norvman!

track to is one of those little pieces of blender that needs some work…

in fact you should avoid ‘track too’ and use ‘damped track’ instead…

however in this instance I think your much better off the ‘IK constraint’

reason being is that the IK constraint is always the last constraint to get figured of all the constraints…
and because your using more than one constraint on one bone , that certainly comes into concideration…

ooopppsss… forgot to post back here…

as norvman pointed out, it’s a problem with your constrainhts…

in the file posted, the foot_L bone has a track to constraint on it. Disable that constraint and the heel looks fine.

Didn’t reallly look into your foot/leg rigging job…

So I can’t advise you on what you have going on there…

Randy