Broken Texturing?

Hello, I am new to this forum. I was hoping I could get some help from someone who knows enough about Blender to know what I must be doing wrong.

I have recently installed the latest blender 2.48a with the second latest Python 2.5.2 on my Windows XP Professional system. I also used the Noob-to-Pro tutorial on the Blender website to familiarize myself with the Blender interface and procedures.

Everything was perfect up until the textured section. Right after the bump mapping tutorial which was flawless, I proceeded to see what a textured object looked like from the “Landscape Modeling I: Basic Terrain” tutorial. Well, it turns out that when it was supposed to show a textured plane, it instead is just a white shaded untextured area.

I tried many different ways of accomplishing a textured object, even downloaded someone’s blender files from the internet to see if an example would work. Nothing works.

I will explain the exact process that I am doing. Tell me where I am going wrong.

User Preferences: File > New > Erase All
( With the default square selected in Object mode… )
Panels: Shading > Material Buttons > Shaders > Spec: = 0.00
Panels: Shading > Texture Buttons > Texture > Texture Type = “Image”
Panels: Shading > Texture Buttons > Image > Click “Load”
Loaded this texture:
3D View: Viewport Shading = “Textured”

At this point, I see the grass texture in the [ Panels: Shading > Texture Buttons > Preview tab ]. I can also see the texture wrapped around the sphere in [ Panels: Shading > Material Buttons > Preview tab ], but I do not see it wrapped around the 3D view cube. Even if i click the Render button on the far bottom right of the 3D view, it just looks like a shiny white square.

Like I said, I tried everything to make it work and I am at a complete loss. The bump mapping tutorial worked perfectly, and performing color changes with [ Panels: Shading > Material Buttons > Material > R/G/B ] also affects both the Preview and the 3D view, but not when a texture is loaded.

What do you guys think is wrong?

Well, it turns out that when it was supposed to show a textured plane, it instead is just a white shaded untextured area.

I had the same problem…so that’s how i solved it:

  1. Select your object
  2. change one of viewports to UV/Image editor
  3. Select every poly of your model (in Edit mode) (A)
  4. In UV/Image editor find an empty space for writing…and by using arrows(Up/Down) button select your image

then texture should appear in your view

The white is called Potato mode, which is where there is a UV Texture without an image. see wiki on UV Unwrapping. You need to use a Texture channel mapped to UV (and then load you UV image as the image texture).