Bug in v 2.69?

When unwapping for cube in cycles I get the wrong number of squares in the map. This happens in both Cycles and Render engines.

Here’s Cycles rendering.

I’ve selected a material, then applied a texture.

See there? Only 3 faces are shown. I have not scaled the map to the image. Notice also that a node for this texture is not applied to the material. Where is it?

So I scale the map and add a texture node to the nodes pane. In the texture control in the nodes pane, I choose the previously loaded texture (I have now opened it three times – 1. To assign the material. 2. Into the UVmap editor. 3. Into the nodes pane.

Here’s a screen shot. The viewing mode in the 3D window is set to texture. Notice that all three visible sides - left, top, and right show the same piece of the texture, in the same orientation.

This is not mapped correctly. The mapping is not applied to the texture and the texture is not appliedd to the material. The only thing that’s right is that 1. The material’s color can be seen. 3. The texture is connected to it. What’s wrong is that the texture is NOT MAPPED.

I’ve been through the above many times. Each time, I choose from the 3D pane, uvUnrwap/cube projection. I never get six sides. I only get three. Why?

I’ve also seen this cube projection give me rectangles, not squares. I’ve also seen the panels for the mapping overlap each other. What is wrong? Am I doing something wrong? Is the software wrong? I’m ONLY trying to map a six sided cube!

Here’s how it works in Blender rendering (a brand new project). I’ve already scaled the 3 panels in the map:

Then I can set the view mode in the 3D port to texture, and I see it places on the cube. Then I render it, and the texture is not shown!


Have you seen this problem? Is it something I’m doing wrong? I’ve followed the directions shown in YouTube videos for both Cyles and Blender engines. These are not working in version 2.69 or my computer is damaged, but it’s only 3 weeks old (new processor, new mainboard, new geforce GTX 650 ti video card, and a monitor so that I can work with Blender.

I’ve made pool balls, courtesy of Neil Hirsig (search for ‘Blender pool balls’) on youtube. This worked. But no mapping was done, other than uvUnwrap/ unwrap.

I’ve made a textured bowl, courtesy of Neil Hirsig.

I’ve made planes, but the maps don’t match the plane. I’ll get a map that’s a square, not a rectangle when a plane is a rectangle. I’ll also get a rectangle, when the plane is a square. Then again, sometimes… just a few times… it has worked right.

So what is wrong?

Last part - “not a rectangle when a plane is a rectangle” is because of not applied scale in Object mode (keys Ctrl-a Scale while in Object mode). Also scaling was done in Object mode previously; try to use scale in edit mode.
Hit “Reset” on UV menu - all faces should sit on top of each other. Could use Smart Unwrap - that will make unwrap all faces separately;
use Seams - you are supposed to get T shaped unwrap if you figure how to ‘cut’ cube.

Select one face - Unwrap that; repeat for other faces. Select and move UV ‘islands’ for unwrapped faces in UV editor - position and scale on image texture as needed.

Read wiki http://wiki.blender.org/index.php/Doc:2.6/Manual/Textures/Mapping/UV/Unwrapping

UV part is the same in both Cycles and Blender Internal render engines. It just tells where texture image is ‘glued’ to the mesh.

Sorry, no bug there.
Blender is amazing in many things except in reading people’s minds. Sometimes it does require the correct input from the user.
Unwrapping can be a very complex task and can be addressed in many different ways
It all depends on the projection you are looking for.

Please read:


@ cegation, the pattern shown for your cube is incorrect too. Try this. Take a piece of paper. Cut it along the outsides as shown in your picture. Then fold it along the creases (the lines inside the perimeter). Can you make that fit around cube? I know you can’t, but try it.

@ cegation. After you have unwrapped, go into Compositing mode. Does your texture show in the nodes pane? No? Okay then try this. Start a new project. Go immediately into Cycles rendering. Remove the existing cube. Add a new cube. Apply a material to it. Don’t apply a texture to it. Unwrap the uvs. in the UV editor, load the texture you want. make sure that the map fits the texture.

Switch to composititing mode. Put a texture node into the nodes pane. Find the texture you already opened, and connect it to the object, not the material. Does this work?

@Eppo, I have no idea what you are talking about. The cube is 2x2x2. The scale is 1x1x1. This is shown in the properties panel (press n). I have not changed the scale. This brings up a good question. If my cube is initially 2x2x2 then why is the scale 1x1x1? And if I change the scale to .5x.5x.5, I now have a cube that is 1x1x1. These numbers don’t make sense.

A cube that is 1x1x1 should have a scale that is 1x1x1. Does this make sense? Then a cube that is 2x2x2, would have a scale that is 2x2x2.

Why does a cube that measures 2x2x2 when it it initially placed, have a scale that is 1x1x1? Why? Explain. Also explain, how scale effects mapping UVs.

The bottom line: version 2.69 of Blender can’t unwrap the simplest 3D form possible, a cube. You have a cube highlighted. It’s in editing mode. You tell it to UV unwrap (as a cube), and it doesn’t know how to do this.

There are four ways to do this:

Anothe bottom line: I’m tired of wasting my time!

Scale is a number you multiply units and get absolute value, like if one makes car/ship/airplane model he makes it scaled say 1:25. While car is 4 meters long, model is 25 times smaller.
Cube (and the rest of the bunch) has ‘blender units’ as a measure (can switch to metric or imperial) and scale, which says how big it is in ‘reality’. Scale can be different on x,y z: you could cut cube in half while in edit mode and then ‘stretch’ it back to the cube shape in object mode. What you did is you changed scale on one axis (e.g. 2:1:1), not the actual edge length. When you ‘apply scale’ edge lengths get recalculated - scale gets back to 1:1:1.
In edit mode you operate directly on edge lengths while in object mode it is scale you change.
This may show up when you try to ‘align’ texture image with your object (do UV mapping): scaled object will be mapped accordingly to actual edge lengths and you could get texture ‘stretching’.
Not related to what you show here - 3 faces (some do overlap) in the UV editor.

Have you tried to use Smart UV Project option yet? And no need to delete and recreate cubes: open Object Data tab (triangle icon) and delete UV coords if you have them in UV maps tab using ‘-’.

Edit: blender knows several other ways to unwrap cube besides ones you show.

I hope you will keep trying and eventually learn to use Blender. It’s going to be hard though if you summarily dismiss the help that people with experience, like Cegaton and Eppo, offer you!

Here are some tips that may help you with this particular problem.

The UV unwrap result is not meant to be a pattern that you can cut out and reassemble into the original object.
It is only to arrange the faces of an object in a two dimensional space called UV space so that every point on each face has a UV coordinate. The value of U and V are 0-1. What you are describing is a CAD process called development, most often used to design sheetmetal structures or cardboard models; it is not something that Blender is designed for, although there are ways to get there.

Compositing mode is only for postrender assembling of images and video sequences etc. into a finished product. It’s not going to be of any help to you here or anytime soon, really.

The scale of an object is distinct from its dimensions. That’s why there are two fields for them. An object that has been scaled only in edit mode has a scale of 1 in object mode. An object that has been scaled in object mode has a scale that is more or less than 1. Applying that scale makes this change permanent and resets its scale back to 1. Conversely, you can CLEAR the scale and it will go back to what it was before any scaling in object mode was done. This is a fundamental way that scale and dimension works in blender and I recommend you take the time to understand it fully.

Cube projection looks at an object from the point of view of the six faces of an imaginary cube aligned to world space and maps what it sees! If any face is exactly behind another face you won’t see its UVs either. A default cube unwrapped in this way will look like a single square in UV. The image you provided looks like a project from view unwrap possibly.
Another possible reason you are seeing only three faces is that when you initially unwrapped the cube you only selected the front three faces, by using box, circle or lasso select. Blender initially unwraps only the selection you give it.

UV unwrapping is quite difficult and the documentation is not extensive.

Incidentally you missed a few ways to unfold a cube - there are at least seven ways.:stuck_out_tongue: